summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortimvisee2021-07-11 16:20:09 +0000
committertimvisee2021-07-11 16:20:09 +0000
commitbb7adde736f4f3210cbeb86c6dc4a57a39bd284f (patch)
tree156ec8f49e38e93a445540e521ad5af196c0f26e
parent77d0f76ee3c9bdbc58393fa333da555f22892f46 (diff)
downloadaur-bb7adde736f4f3210cbeb86c6dc4a57a39bd284f.tar.gz
prs-git
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd8a354ee54b..204f65f4abde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = prs-git
pkgdesc = Secure, fast & convenient password manager CLI using GPG and git to sync (git)
- pkgver = 0.2.11.r0.gb7141e6
+ pkgver = 0.2.13.r5.gb3886d7
pkgrel = 1
url = https://gitlab.com/timvisee/prs
arch = any
@@ -11,10 +11,12 @@ pkgbase = prs-git
depends = gpgme
depends = dbus
depends = libxcb
+ depends = libxkbcommon
+ depends = skim
+ depends = tomb
provides = prs
conflicts = prs
source = git+https://gitlab.com/timvisee/prs
sha512sums = SKIP
pkgname = prs-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 514656c703ca..470511eda363 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,22 @@
# Maintainer: orhun <orhunparmaksiz@gmail.com>
#
# Based on template. Changes made here will be overwritten each release.
-# See: https://gitlab.com/timvisee/prs
+# See: https://gitlab.com/timvisee/prs/-/tree/master/pkg/aur/prs-git
pkgname=prs-git
-pkgver=0.2.11.r0.gb7141e6
+pkgver=0.2.13.r5.gb3886d7
pkgrel=1
pkgdesc="Secure, fast & convenient password manager CLI using GPG and git to sync (git)"
arch=('any')
url="https://gitlab.com/timvisee/prs"
license=('GPL3')
-depends=('gpgme' 'dbus' 'libxcb')
+depends=('gpgme' 'dbus' 'libxcb' 'libxkbcommon' 'skim' 'tomb')
makedepends=('rust' 'python' 'git')
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
source=("git+${url}")
sha512sums=('SKIP')
+_prs_cli_features=alias,clipboard,notify,backend-gpgme,select-skim-bin,tomb
pkgver() {
cd "${pkgname%-git}"
@@ -25,12 +26,12 @@ pkgver() {
build() {
cd "${pkgname%-git}"
- cargo build --package prs-cli --release --locked
+ cargo build --package prs-cli --no-default-features --features $_prs_cli_features --release --locked
}
check() {
cd "${pkgname%-git}"
- cargo test --package prs-cli --release --locked
+ cargo test --package prs-cli --no-default-features --features $_prs_cli_features --release --locked
}
package() {