summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFélix Piédallu2023-05-31 13:49:53 +0200
committerFélix Piédallu2023-05-31 13:50:20 +0200
commit189bce68cbe4ee965c2c71df14bb22bee3a88808 (patch)
tree9faff1b0fac0b80327add98bca907d8bb1e3eb79
parent90b9fc9737c061ef8a2bc3472784dd34593b1757 (diff)
downloadaur-189bce68cbe4ee965c2c71df14bb22bee3a88808.tar.gz
Remove legacy patch
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fix-format-string.patch25
-rw-r--r--PKGBUILD6
3 files changed, 2 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6dbede3f6222..16041abbcccf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = prusa-slicer-git
pkgdesc = G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)
pkgver = 2.6.0.alpha6.r1.g996a72a27
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/prusa3d/PrusaSlicer
arch = i686
arch = x86_64
@@ -19,8 +19,6 @@ pkgbase = prusa-slicer-git
depends = intel-tbb
conflicts = prusa-slicer
source = git+https://github.com/prusa3d/PrusaSlicer
- source = 0001-Fix-format-string.patch
sha256sums = SKIP
- sha256sums = b78fa23a5bccf0a1064f20786bfaede97f0691b6ebb882a698bedc0b3421ec72
pkgname = prusa-slicer-git
diff --git a/0001-Fix-format-string.patch b/0001-Fix-format-string.patch
deleted file mode 100644
index 37ab10cde019..000000000000
--- a/0001-Fix-format-string.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 0bd5f4f6e6548a63a60356f09c533f5ddada8990 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?F=C3=A9lix=20Pi=C3=A9dallu?= <felix@piedallu.me>
-Date: Sat, 11 Mar 2023 12:20:58 +0100
-Subject: [PATCH] Fix format string
-
----
- src/slic3r/GUI/ImGuiWrapper.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/slic3r/GUI/ImGuiWrapper.cpp b/src/slic3r/GUI/ImGuiWrapper.cpp
-index 6b85af966..d48b91522 100644
---- a/src/slic3r/GUI/ImGuiWrapper.cpp
-+++ b/src/slic3r/GUI/ImGuiWrapper.cpp
-@@ -460,7 +460,7 @@ bool ImGuiWrapper::button(const wxString &label, const wxString& tooltip)
-
- if (!tooltip.IsEmpty() && ImGui::IsItemHovered()) {
- auto tooltip_utf8 = into_u8(tooltip);
-- ImGui::SetTooltip(tooltip_utf8.c_str());
-+ ImGui::SetTooltip("%s", tooltip_utf8.c_str());
- }
-
- return ret;
---
-2.39.2
-
diff --git a/PKGBUILD b/PKGBUILD
index 6db40c13b597..8134048c6896 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=prusa-slicer-git
pkgver=2.6.0.alpha6.r1.g996a72a27
-pkgrel=1
+pkgrel=2
pkgdesc='G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)'
arch=('i686' 'x86_64' 'armv6' 'armv6h' 'armv7h')
url='https://github.com/prusa3d/PrusaSlicer'
@@ -35,11 +35,9 @@ depends=(
source=(
"git+${url}"
- '0001-Fix-format-string.patch'
)
sha256sums=(
'SKIP'
- 'b78fa23a5bccf0a1064f20786bfaede97f0691b6ebb882a698bedc0b3421ec72'
)
conflicts=('prusa-slicer')
@@ -49,8 +47,6 @@ pkgver() {
prepare() {
cd "PrusaSlicer"
- # Fix build
- patch -p1 < "$srcdir/0001-Fix-format-string.patch"
rm "$srcdir/PrusaSlicer/cmake/modules/FindEXPAT.cmake"
}