summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFélix Piédallu2023-03-11 13:53:43 +0100
committerFélix Piédallu2023-03-11 13:55:13 +0100
commit1d46fdbd2a41bf9eabe06f63e94c0731c90bc8cf (patch)
treec8f7bdccb4559d7f444fb0a285e506738702e16f
parenta4ba8c4dc8c1cf5abd8c76e28d87471d7aba592d (diff)
downloadaur-1d46fdbd2a41bf9eabe06f63e94c0731c90bc8cf.tar.gz
Go back to full-static dependencies. Disappointing but meh
-rw-r--r--.SRCINFO18
-rw-r--r--0001-Fix-format-string.patch25
-rw-r--r--PKGBUILD78
-rw-r--r--prusa-slicer-boost-placeholders.patch9
4 files changed, 60 insertions, 70 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f6072450f62..20a8669086d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = prusa-slicer-git
pkgdesc = G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)
- pkgver = 2.6.0.alpha0.r156.gc3bdf2fc2
+ pkgver = 2.6.0.alpha5
pkgrel = 1
url = https://github.com/prusa3d/PrusaSlicer
arch = i686
@@ -12,26 +12,14 @@ pkgbase = prusa-slicer-git
makedepends = cmake
makedepends = ninja
makedepends = clang
- makedepends = boost
- makedepends = cereal
makedepends = eigen
makedepends = gtest
- depends = boost-libs
- depends = cgal
- depends = curl
depends = dbus
- depends = glew
depends = intel-tbb
- depends = libpng
- depends = nlopt
- depends = openvdb
- depends = qhull
conflicts = prusa-slicer
source = git+https://github.com/prusa3d/PrusaSlicer
- source = prusa-slicer-boost-placeholders.patch
- source = https://github.com/prusa3d/wxWidgets/archive/489f6118256853cf5b299d595868641938566cdb/wxWidgets-489f6118256853cf5b299d595868641938566cdb.tar.gz
- sha256sums = SKIP
- sha256sums = 58cae07a418a797222f4cb10950fa2fd7afb7570519785b082cc7d7e7f407c02
+ source = 0001-Fix-format-string.patch
sha256sums = SKIP
+ sha256sums = b78fa23a5bccf0a1064f20786bfaede97f0691b6ebb882a698bedc0b3421ec72
pkgname = prusa-slicer-git
diff --git a/0001-Fix-format-string.patch b/0001-Fix-format-string.patch
new file mode 100644
index 000000000000..37ab10cde019
--- /dev/null
+++ b/0001-Fix-format-string.patch
@@ -0,0 +1,25 @@
+From 0bd5f4f6e6548a63a60356f09c533f5ddada8990 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?F=C3=A9lix=20Pi=C3=A9dallu?= <felix@piedallu.me>
+Date: Sat, 11 Mar 2023 12:20:58 +0100
+Subject: [PATCH] Fix format string
+
+---
+ src/slic3r/GUI/ImGuiWrapper.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/slic3r/GUI/ImGuiWrapper.cpp b/src/slic3r/GUI/ImGuiWrapper.cpp
+index 6b85af966..d48b91522 100644
+--- a/src/slic3r/GUI/ImGuiWrapper.cpp
++++ b/src/slic3r/GUI/ImGuiWrapper.cpp
+@@ -460,7 +460,7 @@ bool ImGuiWrapper::button(const wxString &label, const wxString& tooltip)
+
+ if (!tooltip.IsEmpty() && ImGui::IsItemHovered()) {
+ auto tooltip_utf8 = into_u8(tooltip);
+- ImGui::SetTooltip(tooltip_utf8.c_str());
++ ImGui::SetTooltip("%s", tooltip_utf8.c_str());
+ }
+
+ return ret;
+--
+2.39.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 9e84ae4a7d41..e10113d4e57b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Salamandar <felix@piedallu.me>
pkgname=prusa-slicer-git
-pkgver=2.6.0.alpha0.r156.gc3bdf2fc2
+pkgver=2.6.0.alpha5
pkgrel=1
pkgdesc='G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)'
arch=('i686' 'x86_64' 'armv6' 'armv6h' 'armv7h')
@@ -11,39 +11,34 @@ makedepends=(
'cmake'
'ninja'
'clang'
- 'boost'
- 'cereal'
+ # 'boost'
+ # 'cereal'
'eigen'
'gtest'
)
depends=(
- 'boost-libs'
- 'cgal'
- 'curl'
+ # 'boost-libs'
+ # 'cgal'
+ # 'curl'
'dbus'
- 'glew'
+ # 'glew'
'intel-tbb'
- 'libpng'
- 'nlopt'
- 'openvdb'
- 'qhull'
+ # 'libpng'
+ # 'nanosvg_fltk'
+ # 'nlopt'
+ # 'openvdb'
+ # 'qhull'
# wx 3.2 is not supported yet https://github.com/prusa3d/PrusaSlicer/issues/8299
# 'wxgtk3'
)
-# prusa-slicer use a patched wxWidgets and does not work with upstream, commit pinned in
-# https://github.com/prusa3d/PrusaSlicer/blob/version_${pkgver}/deps/wxWidgets/wxWidgets.cmake
-_wxcommit=489f6118256853cf5b299d595868641938566cdb
-
source=(
"git+${url}"
- 'prusa-slicer-boost-placeholders.patch'
- "https://github.com/prusa3d/wxWidgets/archive/${_wxcommit}/wxWidgets-${_wxcommit}.tar.gz"
+ '0001-Fix-format-string.patch'
)
sha256sums=(
'SKIP'
- '58cae07a418a797222f4cb10950fa2fd7afb7570519785b082cc7d7e7f407c02'
- 'SKIP'
+ 'b78fa23a5bccf0a1064f20786bfaede97f0691b6ebb882a698bedc0b3421ec72'
)
conflicts=('prusa-slicer')
@@ -53,41 +48,30 @@ pkgver() {
prepare() {
cd "PrusaSlicer"
- # Fix build with Boost 1.76.0
- patch -p1 < "$srcdir/prusa-slicer-boost-placeholders.patch"
+ # Fix build
+ patch -p1 < "$srcdir/0001-Fix-format-string.patch"
+
+ rm "$srcdir/PrusaSlicer/cmake/modules/FindEXPAT.cmake"
}
+_build_deps() {
+ cmake -B deps/build -S PrusaSlicer/deps -G Ninja \
+ -DDEP_WX_GTK3=ON \
+ -DDEP_DEBUG=OFF \
+ -DDEP_DOWNLOAD_DIR=deps/downloads \
+ -DDESTDIR="$deps_destdir"
-_build_wx_static() {
- cmake -B deps -S wxWidgets-${_wxcommit} -G Ninja\
- -DCMAKE_INSTALL_PREFIX="$deps_install_dir" \
- -DCMAKE_POSITION_INDEPENDENT_CODE=ON \
- -DBUILD_SHARED_LIBS=OFF \
- -DwxBUILD_TOOLKIT=gtk3 \
- -DwxUSE_MEDIACTRL=OFF \
- -DwxUSE_DETECT_SM=OFF \
- -DwxUSE_UNICODE=ON \
- -DwxUSE_UNICODE_UTF8=ON \
- -DwxUSE_OPENGL=ON \
- -DwxUSE_LIBPNG=sys \
- -DwxUSE_ZLIB=sys \
- -DwxUSE_REGEX=builtin \
- -DwxUSE_LIBJPEG=sys \
- -DwxUSE_LIBTIFF=sys \
- -DwxUSE_EXPAT=sys \
- -DwxUSE_LIBLZMA=sys \
- -DwxUSE_LIBSDL=OFF \
- -DwxUSE_XTEST=OFF
- cmake --build deps
- cmake --install deps
+ cmake --build deps/build -j1
+ cmake --install deps/build
}
build() {
export CC=clang
export CXX=clang++
- deps_install_dir="$srcdir/deps/destdir/usr/local"
- _build_wx_static
+ deps_destdir="$srcdir/deps/destdir"
+ deps_install_dir="$deps_destdir/usr/local"
+ _build_deps
cmake_args=(
-DCMAKE_INSTALL_PREFIX=/usr
@@ -95,7 +79,9 @@ build() {
-DSLIC3R_FHS=ON
-DSLIC3R_PCH=OFF
-DSLIC3R_GTK=3
- -DOPENVDB_FIND_MODULE_PATH=/usr/lib/cmake/OpenVDB
+ # -DOPENVDB_FIND_MODULE_PATH=/usr/lib/cmake/OpenVDB
+ -DOPENVDB_USE_STATIC_LIBS=ON
+ -DSLIC3R_STATIC=1
)
# for statically linked wx-gtk3
cmake_args+=(
diff --git a/prusa-slicer-boost-placeholders.patch b/prusa-slicer-boost-placeholders.patch
deleted file mode 100644
index ba925512caa3..000000000000
--- a/prusa-slicer-boost-placeholders.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-diff --git a/src/libslic3r/MeshBoolean.cpp b/src/libslic3r/MeshBoolean.cpp
-index 346d7a954..64d52eca4 100644
---- a/src/libslic3r/MeshBoolean.cpp
-+++ b/src/libslic3r/MeshBoolean.cpp
-@@ -1,3 +1,4 @@
-+#define BOOST_BIND_GLOBAL_PLACEHOLDERS
- #include "Exception.hpp"
- #include "MeshBoolean.hpp"
- #include "libslic3r/TriangleMesh.hpp"