summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFélix Piédallu2021-11-05 11:55:01 +0100
committerFélix Piédallu2021-11-05 11:55:01 +0100
commit6d590dd7544da6467a80e0d04f26df506ae69d90 (patch)
tree72c1d5b25a9438cbc6cae7f62c19ac617e4b0a1e
parentd85aeba201fd2c31a97da6d33116861de735808f (diff)
downloadaur-6d590dd7544da6467a80e0d04f26df506ae69d90.tar.gz
Remove now useless openexr3 patch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--prusa-slicer-openexr3.patch77
3 files changed, 0 insertions, 83 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8679c8c297f1..73ab449c08d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -27,11 +27,9 @@ pkgbase = prusa-slicer-git
conflicts = prusa-slicer
source = git+https://github.com/prusa3d/PrusaSlicer
source = prusa-slicer.desktop
- source = prusa-slicer-openexr3.patch
source = prusa-slicer-boost-placeholders.patch
sha256sums = SKIP
sha256sums = 26b66701cb2512f0d524add44689e2478c0b875f73103034e74544a9574782c5
- sha256sums = 325d97f8e648da1c8e90e3b30cf172afcc49f05f3e79971e6dacb9adf72f5bf9
sha256sums = 58cae07a418a797222f4cb10950fa2fd7afb7570519785b082cc7d7e7f407c02
pkgname = prusa-slicer-git
diff --git a/PKGBUILD b/PKGBUILD
index 552c2671f73c..191c929a749b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,13 +31,11 @@ makedepends=(
source=(
"git+${url}"
'prusa-slicer.desktop'
- 'prusa-slicer-openexr3.patch'
'prusa-slicer-boost-placeholders.patch'
)
sha256sums=(
'SKIP'
'26b66701cb2512f0d524add44689e2478c0b875f73103034e74544a9574782c5'
- '325d97f8e648da1c8e90e3b30cf172afcc49f05f3e79971e6dacb9adf72f5bf9'
'58cae07a418a797222f4cb10950fa2fd7afb7570519785b082cc7d7e7f407c02'
)
conflicts=('prusa-slicer')
@@ -49,8 +47,6 @@ pkgver() {
prepare() {
cd "PrusaSlicer"
- # Fix build with openEXR 3
- patch -p1 < "$srcdir/prusa-slicer-openexr3.patch"
# Fix build with Boost 1.76.0
patch -p1 < "$srcdir/prusa-slicer-boost-placeholders.patch"
}
diff --git a/prusa-slicer-openexr3.patch b/prusa-slicer-openexr3.patch
deleted file mode 100644
index 1b95fac1deeb..000000000000
--- a/prusa-slicer-openexr3.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-diff --git a/cmake/modules/FindOpenVDB.cmake b/cmake/modules/FindOpenVDB.cmake
-index 4fde5fa4a..7fc13e059 100644
---- a/cmake/modules/FindOpenVDB.cmake
-+++ b/cmake/modules/FindOpenVDB.cmake
-@@ -347,28 +347,10 @@ macro(just_fail msg)
- return()
- endmacro()
-
--find_package(IlmBase QUIET)
--if(NOT IlmBase_FOUND)
-- pkg_check_modules(IlmBase QUIET IlmBase)
--endif()
--if (IlmBase_FOUND AND NOT TARGET IlmBase::Half)
-- message(STATUS "Falling back to IlmBase found by pkg-config...")
--
-- find_library(IlmHalf_LIBRARY NAMES Half)
-- if(IlmHalf_LIBRARY-NOTFOUND OR NOT IlmBase_INCLUDE_DIRS)
-- just_fail("IlmBase::Half can not be found!")
-- endif()
--
-- add_library(IlmBase::Half UNKNOWN IMPORTED)
-- set_target_properties(IlmBase::Half PROPERTIES
-- IMPORTED_LOCATION "${IlmHalf_LIBRARY}"
-- INTERFACE_INCLUDE_DIRECTORIES "${IlmBase_INCLUDE_DIRS}")
--elseif(NOT IlmBase_FOUND)
-- just_fail("IlmBase::Half can not be found!")
--endif()
- find_package(TBB ${_quiet} ${_required} COMPONENTS tbb)
- find_package(ZLIB ${_quiet} ${_required})
- find_package(Boost ${_quiet} ${_required} COMPONENTS iostreams system )
-+find_package(Imath CONFIG)
-
- # Use GetPrerequisites to see which libraries this OpenVDB lib has linked to
- # which we can query for optional deps. This basically runs ldd/otoll/objdump
-@@ -419,7 +401,7 @@ foreach(PREREQUISITE ${_OPENVDB_PREREQUISITE_LIST})
- set(OpenVDB_USES_LOG4CPLUS ON)
- endif()
-
-- string(FIND ${PREREQUISITE} "IlmImf" _HAS_DEP)
-+ string(FIND ${PREREQUISITE} "OpenEXR" _HAS_DEP)
- if(NOT ${_HAS_DEP} EQUAL -1)
- set(OpenVDB_USES_ILM ON)
- endif()
-@@ -450,11 +432,7 @@ if(OpenVDB_USES_LOG4CPLUS)
- find_package(Log4cplus ${_quiet} ${_required})
- endif()
-
--if(OpenVDB_USES_ILM)
-- find_package(IlmBase ${_quiet} ${_required})
--endif()
--
--if(OpenVDB_USES_EXR)
-+if(OpenVDB_USES_ILM OR OpenVDB_USES_EXR)
- find_package(OpenEXR ${_quiet} ${_required})
- endif()
-
-@@ -471,7 +449,7 @@ endif()
- set(_OPENVDB_VISIBLE_DEPENDENCIES
- Boost::iostreams
- Boost::system
-- IlmBase::Half
-+ Imath::Imath
- )
-
- set(_OPENVDB_DEFINITIONS)
-@@ -481,10 +459,7 @@ endif()
-
- if(OpenVDB_USES_EXR)
- list(APPEND _OPENVDB_VISIBLE_DEPENDENCIES
-- IlmBase::IlmThread
-- IlmBase::Iex
-- IlmBase::Imath
-- OpenEXR::IlmImf
-+ OpenEXR::OpenEXR
- )
- list(APPEND _OPENVDB_DEFINITIONS "-DOPENVDB_TOOLS_RAYTRACER_USE_EXR")
- endif()