summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFélix Piédallu2021-11-05 10:52:37 +0100
committerFélix Piédallu2021-11-05 10:53:03 +0100
commit8d0186b097a0106b025ffe1bb975a341b336f902 (patch)
tree0672c617363eef65d520152a23f3ba1567f85ca9
parent13e0c7760407170ae5d082bde2cebe2e1c144784 (diff)
downloadaur-8d0186b097a0106b025ffe1bb975a341b336f902.tar.gz
Add patch for boost 1.76.0. Also download github file.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--prusa-slicer-boost-placeholders.patch9
-rw-r--r--prusa-slicer-openexr3.patch77
4 files changed, 98 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e785eaab0d9..f389a4bdbb53 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = prusa-slicer-git
pkgdesc = G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)
pkgver = 2.4.0.beta1.r76.g7520e2f19
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/prusa3d/PrusaSlicer
arch = i686
arch = x86_64
@@ -27,9 +27,11 @@ pkgbase = prusa-slicer-git
conflicts = prusa-slicer
source = git+https://github.com/prusa3d/PrusaSlicer
source = prusa-slicer.desktop
- source = https://raw.githubusercontent.com/archlinux/svntogit-community/1dea61c0b581ff5001d073689f68b0323740be93/trunk/prusa-slicer-openexr3.patch
+ source = prusa-slicer-openexr3.patch
+ source = prusa-slicer-boost-placeholders.patch
sha256sums = SKIP
sha256sums = 26b66701cb2512f0d524add44689e2478c0b875f73103034e74544a9574782c5
sha256sums = 1ef7c22f641b7c18de212202c21f14f6533834a36d7fe0c2b322bc9a13804c6b
+ sha256sums = 58cae07a418a797222f4cb10950fa2fd7afb7570519785b082cc7d7e7f407c02
pkgname = prusa-slicer-git
diff --git a/PKGBUILD b/PKGBUILD
index a68ee0627f6b..81bef7df289b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgname=prusa-slicer
pkgname=${_pkgname}-git
pkgver=2.4.0.beta1.r76.g7520e2f19
-pkgrel=1
+pkgrel=2
pkgdesc='G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)'
arch=('i686' 'x86_64' 'armv6' 'armv6h' 'armv7h')
url='https://github.com/prusa3d/PrusaSlicer'
@@ -31,12 +31,14 @@ makedepends=(
source=(
"git+${url}"
'prusa-slicer.desktop'
- 'https://raw.githubusercontent.com/archlinux/svntogit-community/1dea61c0b581ff5001d073689f68b0323740be93/trunk/prusa-slicer-openexr3.patch'
+ 'prusa-slicer-openexr3.patch'
+ 'prusa-slicer-boost-placeholders.patch'
)
sha256sums=(
'SKIP'
'26b66701cb2512f0d524add44689e2478c0b875f73103034e74544a9574782c5'
'1ef7c22f641b7c18de212202c21f14f6533834a36d7fe0c2b322bc9a13804c6b'
+ '58cae07a418a797222f4cb10950fa2fd7afb7570519785b082cc7d7e7f407c02'
)
conflicts=('prusa-slicer')
@@ -47,7 +49,10 @@ pkgver() {
prepare() {
cd "PrusaSlicer"
- patch -p1 < "$srcdir/prusa-slicer-openexr3.patch" # Fix build with openEXR 3
+ # Fix build with openEXR 3
+ patch -p1 < "$srcdir/prusa-slicer-openexr3.patch"
+ # Fix build with Boost 1.76.0
+ patch -p1 < "$srcdir/prusa-slicer-boost-placeholders.patch"
}
build() {
diff --git a/prusa-slicer-boost-placeholders.patch b/prusa-slicer-boost-placeholders.patch
new file mode 100644
index 000000000000..ba925512caa3
--- /dev/null
+++ b/prusa-slicer-boost-placeholders.patch
@@ -0,0 +1,9 @@
+diff --git a/src/libslic3r/MeshBoolean.cpp b/src/libslic3r/MeshBoolean.cpp
+index 346d7a954..64d52eca4 100644
+--- a/src/libslic3r/MeshBoolean.cpp
++++ b/src/libslic3r/MeshBoolean.cpp
+@@ -1,3 +1,4 @@
++#define BOOST_BIND_GLOBAL_PLACEHOLDERS
+ #include "Exception.hpp"
+ #include "MeshBoolean.hpp"
+ #include "libslic3r/TriangleMesh.hpp"
diff --git a/prusa-slicer-openexr3.patch b/prusa-slicer-openexr3.patch
new file mode 100644
index 000000000000..772c77bf5e6a
--- /dev/null
+++ b/prusa-slicer-openexr3.patch
@@ -0,0 +1,77 @@
+diff --git a/cmake/modules/FindOpenVDB.cmake b/cmake/modules/FindOpenVDB.cmake
+index 02420fed8..4b93111ab 100644
+--- a/cmake/modules/FindOpenVDB.cmake
++++ b/cmake/modules/FindOpenVDB.cmake
+@@ -326,28 +326,10 @@ macro(just_fail msg)
+ return()
+ endmacro()
+
+-find_package(IlmBase QUIET COMPONENTS Half)
+-if(NOT IlmBase_FOUND)
+- pkg_check_modules(IlmBase QUIET IlmBase)
+-endif()
+-if (IlmBase_FOUND AND NOT TARGET IlmBase::Half)
+- message(STATUS "Falling back to IlmBase found by pkg-config...")
+-
+- find_library(IlmHalf_LIBRARY NAMES Half)
+- if(IlmHalf_LIBRARY-NOTFOUND OR NOT IlmBase_INCLUDE_DIRS)
+- just_fail("IlmBase::Half can not be found!")
+- endif()
+-
+- add_library(IlmBase::Half UNKNOWN IMPORTED)
+- set_target_properties(IlmBase::Half PROPERTIES
+- IMPORTED_LOCATION "${IlmHalf_LIBRARY}"
+- INTERFACE_INCLUDE_DIRECTORIES "${IlmBase_INCLUDE_DIRS}")
+-elseif(NOT IlmBase_FOUND)
+- just_fail("IlmBase::Half can not be found!")
+-endif()
+ find_package(TBB ${_quiet} ${_required} COMPONENTS tbb)
+ find_package(ZLIB ${_quiet} ${_required})
+ find_package(Boost ${_quiet} ${_required} COMPONENTS iostreams system )
++find_package(Imath CONFIG)
+
+ # Use GetPrerequisites to see which libraries this OpenVDB lib has linked to
+ # which we can query for optional deps. This basically runs ldd/otoll/objdump
+@@ -398,7 +380,7 @@ foreach(PREREQUISITE ${_OPENVDB_PREREQUISITE_LIST})
+ set(OpenVDB_USES_LOG4CPLUS ON)
+ endif()
+
+- string(FIND ${PREREQUISITE} "IlmImf" _HAS_DEP)
++ string(FIND ${PREREQUISITE} "OpenEXR" _HAS_DEP)
+ if(NOT ${_HAS_DEP} EQUAL -1)
+ set(OpenVDB_USES_ILM ON)
+ endif()
+@@ -429,11 +411,7 @@ if(OpenVDB_USES_LOG4CPLUS)
+ find_package(Log4cplus ${_quiet} ${_required})
+ endif()
+
+-if(OpenVDB_USES_ILM)
+- find_package(IlmBase ${_quiet} ${_required})
+-endif()
+-
+-if(OpenVDB_USES_EXR)
++if(OpenVDB_USES_ILM OR OpenVDB_USES_EXR)
+ find_package(OpenEXR ${_quiet} ${_required})
+ endif()
+
+@@ -450,7 +428,7 @@ endif()
+ set(_OPENVDB_VISIBLE_DEPENDENCIES
+ Boost::iostreams
+ Boost::system
+- IlmBase::Half
++ Imath::Imath
+ )
+
+ set(_OPENVDB_DEFINITIONS)
+@@ -460,10 +438,7 @@ endif()
+
+ if(OpenVDB_USES_EXR)
+ list(APPEND _OPENVDB_VISIBLE_DEPENDENCIES
+- IlmBase::IlmThread
+- IlmBase::Iex
+- IlmBase::Imath
+- OpenEXR::IlmImf
++ OpenEXR::OpenEXR
+ )
+ list(APPEND _OPENVDB_DEFINITIONS "-DOPENVDB_TOOLS_RAYTRACER_USE_EXR")
+ endif()