summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSalamandar2020-12-09 21:25:05 +0000
committerSalamandar2020-12-09 21:25:05 +0000
commitb362e405b23d9ea5f5d1c94b7524215f6b9c70fa (patch)
treee1c02c8467f4b8e6511494d46b05259574f52b0e
parent25f80d3c35577ba0ef6856da15515b851af4d335 (diff)
downloadaur-b362e405b23d9ea5f5d1c94b7524215f6b9c70fa.tar.gz
Do not depend on qhull anymore, use the one provided in the repo
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
-rw-r--r--qhull.patch13
3 files changed, 27 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed6371ab668c..7d7fc120e766 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = prusa-slicer-git
pkgdesc = G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)
- pkgver = 2.3.0.alpha0.r312.g548497bba
- pkgrel = 2
+ pkgver = 2.3.0.beta2.r118.g06df87da3
+ pkgrel = 3
url = https://github.com/prusa3d/PrusaSlicer
arch = i686
arch = x86_64
@@ -23,12 +23,13 @@ pkgbase = prusa-slicer-git
depends = nlopt
depends = openvdb
depends = wxgtk3
- depends = qhull
conflicts = prusa-slicer
source = git+https://github.com/prusa3d/PrusaSlicer
source = prusa-slicer.desktop
+ source = qhull.patch
sha256sums = SKIP
sha256sums = 26b66701cb2512f0d524add44689e2478c0b875f73103034e74544a9574782c5
+ sha256sums = 877a4de66a714e4fae22e507dba8ddf117e6310165128fb0d46dc239a4e1aeb5
pkgname = prusa-slicer-git
diff --git a/PKGBUILD b/PKGBUILD
index 4c0f983d591c..14d1730f8e9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname=prusa-slicer
pkgname=${_pkgname}-git
-pkgver=2.3.0.alpha0.r312.g548497bba
-pkgrel=2
+pkgver=2.3.0.beta2.r118.g06df87da3
+pkgrel=3
pkgdesc='G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)'
arch=('i686' 'x86_64' 'armv6' 'armv6h' 'armv7h')
url='https://github.com/prusa3d/PrusaSlicer'
@@ -18,7 +18,7 @@ depends=(
'nlopt'
'openvdb'
'wxgtk3'
- 'qhull'
+ # 'qhull'
)
makedepends=(
'cmake'
@@ -31,10 +31,12 @@ makedepends=(
source=(
"git+${url}"
'prusa-slicer.desktop'
+ 'qhull.patch'
)
sha256sums=(
'SKIP'
'26b66701cb2512f0d524add44689e2478c0b875f73103034e74544a9574782c5'
+ '877a4de66a714e4fae22e507dba8ddf117e6310165128fb0d46dc239a4e1aeb5'
)
conflicts=('prusa-slicer')
@@ -43,6 +45,11 @@ pkgver() {
git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^version_//'
}
+prepare() {
+ cd "PrusaSlicer"
+ patch --forward --strip=1 --input="${srcdir}/qhull.patch"
+}
+
build() {
cd "${srcdir}/PrusaSlicer"
mkdir -p build
diff --git a/qhull.patch b/qhull.patch
new file mode 100644
index 000000000000..89382c3fbeae
--- /dev/null
+++ b/qhull.patch
@@ -0,0 +1,13 @@
+diff --git a/src/qhull/CMakeLists.txt b/src/qhull/CMakeLists.txt
+index ab9aba9af..1db993dcd 100644
+--- a/src/qhull/CMakeLists.txt
++++ b/src/qhull/CMakeLists.txt
+@@ -10,7 +10,7 @@
+
+ # see bug report: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=925540
+
+-find_package(Qhull 7.2 QUIET)
++# find_package(Qhull 7.2 QUIET)
+
+ add_library(qhull INTERFACE)
+