summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFélix Piédallu2021-11-05 11:40:52 +0100
committerFélix Piédallu2021-11-05 11:40:52 +0100
commitd85aeba201fd2c31a97da6d33116861de735808f (patch)
treee939e5243717c6bef849156c26d9a5f2d896aea8
parent8d0186b097a0106b025ffe1bb975a341b336f902 (diff)
downloadaur-d85aeba201fd2c31a97da6d33116861de735808f.tar.gz
Fix openexr3 patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--prusa-slicer-openexr3.patch14
3 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f389a4bdbb53..8679c8c297f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = prusa-slicer-git
pkgdesc = G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)
- pkgver = 2.4.0.beta1.r76.g7520e2f19
- pkgrel = 2
+ pkgver = 2.4.0.beta1.r65.gaff9e1f7e
+ pkgrel = 1
url = https://github.com/prusa3d/PrusaSlicer
arch = i686
arch = x86_64
@@ -31,7 +31,7 @@ pkgbase = prusa-slicer-git
source = prusa-slicer-boost-placeholders.patch
sha256sums = SKIP
sha256sums = 26b66701cb2512f0d524add44689e2478c0b875f73103034e74544a9574782c5
- sha256sums = 1ef7c22f641b7c18de212202c21f14f6533834a36d7fe0c2b322bc9a13804c6b
+ sha256sums = 325d97f8e648da1c8e90e3b30cf172afcc49f05f3e79971e6dacb9adf72f5bf9
sha256sums = 58cae07a418a797222f4cb10950fa2fd7afb7570519785b082cc7d7e7f407c02
pkgname = prusa-slicer-git
diff --git a/PKGBUILD b/PKGBUILD
index 81bef7df289b..552c2671f73c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname=prusa-slicer
pkgname=${_pkgname}-git
-pkgver=2.4.0.beta1.r76.g7520e2f19
-pkgrel=2
+pkgver=2.4.0.beta1.r65.gaff9e1f7e
+pkgrel=1
pkgdesc='G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)'
arch=('i686' 'x86_64' 'armv6' 'armv6h' 'armv7h')
url='https://github.com/prusa3d/PrusaSlicer'
@@ -37,7 +37,7 @@ source=(
sha256sums=(
'SKIP'
'26b66701cb2512f0d524add44689e2478c0b875f73103034e74544a9574782c5'
- '1ef7c22f641b7c18de212202c21f14f6533834a36d7fe0c2b322bc9a13804c6b'
+ '325d97f8e648da1c8e90e3b30cf172afcc49f05f3e79971e6dacb9adf72f5bf9'
'58cae07a418a797222f4cb10950fa2fd7afb7570519785b082cc7d7e7f407c02'
)
conflicts=('prusa-slicer')
diff --git a/prusa-slicer-openexr3.patch b/prusa-slicer-openexr3.patch
index 772c77bf5e6a..1b95fac1deeb 100644
--- a/prusa-slicer-openexr3.patch
+++ b/prusa-slicer-openexr3.patch
@@ -1,12 +1,12 @@
diff --git a/cmake/modules/FindOpenVDB.cmake b/cmake/modules/FindOpenVDB.cmake
-index 02420fed8..4b93111ab 100644
+index 4fde5fa4a..7fc13e059 100644
--- a/cmake/modules/FindOpenVDB.cmake
+++ b/cmake/modules/FindOpenVDB.cmake
-@@ -326,28 +326,10 @@ macro(just_fail msg)
+@@ -347,28 +347,10 @@ macro(just_fail msg)
return()
endmacro()
--find_package(IlmBase QUIET COMPONENTS Half)
+-find_package(IlmBase QUIET)
-if(NOT IlmBase_FOUND)
- pkg_check_modules(IlmBase QUIET IlmBase)
-endif()
@@ -32,7 +32,7 @@ index 02420fed8..4b93111ab 100644
# Use GetPrerequisites to see which libraries this OpenVDB lib has linked to
# which we can query for optional deps. This basically runs ldd/otoll/objdump
-@@ -398,7 +380,7 @@ foreach(PREREQUISITE ${_OPENVDB_PREREQUISITE_LIST})
+@@ -419,7 +401,7 @@ foreach(PREREQUISITE ${_OPENVDB_PREREQUISITE_LIST})
set(OpenVDB_USES_LOG4CPLUS ON)
endif()
@@ -41,7 +41,7 @@ index 02420fed8..4b93111ab 100644
if(NOT ${_HAS_DEP} EQUAL -1)
set(OpenVDB_USES_ILM ON)
endif()
-@@ -429,11 +411,7 @@ if(OpenVDB_USES_LOG4CPLUS)
+@@ -450,11 +432,7 @@ if(OpenVDB_USES_LOG4CPLUS)
find_package(Log4cplus ${_quiet} ${_required})
endif()
@@ -54,7 +54,7 @@ index 02420fed8..4b93111ab 100644
find_package(OpenEXR ${_quiet} ${_required})
endif()
-@@ -450,7 +428,7 @@ endif()
+@@ -471,7 +449,7 @@ endif()
set(_OPENVDB_VISIBLE_DEPENDENCIES
Boost::iostreams
Boost::system
@@ -63,7 +63,7 @@ index 02420fed8..4b93111ab 100644
)
set(_OPENVDB_DEFINITIONS)
-@@ -460,10 +438,7 @@ endif()
+@@ -481,10 +459,7 @@ endif()
if(OpenVDB_USES_EXR)
list(APPEND _OPENVDB_VISIBLE_DEPENDENCIES