summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchengxuncc2023-01-24 08:38:04 -0500
committerchengxuncc2023-01-24 08:38:04 -0500
commit82fa2498b8b326b4cfd1af230dc217353adfcd1e (patch)
tree78440eef66aab3f20958021a7a7be589074d6bc0
parentaabb4a5d219bdd81192662dc8b7adf31500ebe62 (diff)
downloadaur-82fa2498b8b326b4cfd1af230dc217353adfcd1e.tar.gz
update version to v3.2.0
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD59
-rw-r--r--prysm-beacon-chain.service29
-rw-r--r--prysm-client-stats.service10
-rw-r--r--prysm-slasher.service33
-rw-r--r--prysm-validator.service10
-rw-r--r--prysm-validator@.service14
-rw-r--r--prysm.sysusers1
8 files changed, 64 insertions, 114 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e78169b0cfd8..5cea28ae0fc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,16 @@
pkgbase = prysm
- pkgdesc = go implementation of the Ethereum 2.0 blockchain
- pkgver = 1.0.0_alpha.23
+ pkgdesc = Prysm is an Ethereum proof-of-stake client written in Go.
+ pkgver = 3.2.0
pkgrel = 1
url = https://prysmaticlabs.com/
arch = x86_64
+ arch = arm64
license = GPLv3
- makedepends = go
- options = emptydirs
- source = git+https://github.com/prysmaticlabs/prysm.git#tag=v1.0.0-alpha.23
- source = prysm-validator@.service
source = prysm-beacon-chain.service
- source = prysm-slasher.service
- source = prysm.sysusers
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ source = prysm-client-stats.service
+ source = prysm-validator.service
+ sha256sums = 6b1f2d44a7bd3c5e6c9c72dc60d23159fe76d4d04d7b685f50499e92cba476cf
+ sha256sums = cc19fe37cd80972e3a214f5de577b315996e428c8e93cb362c5beb8204d8a173
+ sha256sums = 143147f19424a17147d342d1ac4006d8a154dbbb9e4b5a2f8e594d43e90bd305
pkgname = prysm
-
diff --git a/PKGBUILD b/PKGBUILD
index f3cf166ba64a..31856af635e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,48 @@
# Maintainer: Spider.007 <aur@spider007.net>
+# Maintainer: chengxuncc <chengxuncc@gmail.com>
+
pkgname=prysm
-pkgver=1.0.0_alpha.23
+pkgver=3.2.0
pkgrel=1
-pkgdesc="go implementation of the Ethereum 2.0 blockchain"
-arch=('x86_64')
+pkgdesc="Prysm is an Ethereum proof-of-stake client written in Go."
+arch=('x86_64' 'arm64')
url="https://prysmaticlabs.com/"
license=(GPLv3)
-options=('emptydirs')
-makedepends=(
- go
-)
source=(
- git+https://github.com/prysmaticlabs/prysm.git#tag=v${pkgver/_/-}
- prysm-validator@.service
prysm-beacon-chain.service
- prysm-slasher.service
- prysm.sysusers
+ prysm-client-stats.service
+ prysm-validator.service
)
-sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+sha256sums=('6b1f2d44a7bd3c5e6c9c72dc60d23159fe76d4d04d7b685f50499e92cba476cf'
+ 'cc19fe37cd80972e3a214f5de577b315996e428c8e93cb362c5beb8204d8a173'
+ '143147f19424a17147d342d1ac4006d8a154dbbb9e4b5a2f8e594d43e90bd305')
+
+downloadBinary(){
+ binary=$1
+ prysmArch=${arch/x86_64/amd64}
+ prysmArch=${prysmArch/aarch64/arm64}
+ file="$binary-v${pkgver}-linux-$prysmArch"
+ echo "https://prysmaticlabs.com/releases/$file"
+ curl -f -L "https://prysmaticlabs.com/releases/$file" -o "$file"
+ echo "https://prysmaticlabs.com/releases/$file.sha256"
+ curl -f -L "https://prysmaticlabs.com/releases/$file.sha256" -o "$file.sha256"
+ sha256sum -c "$file.sha256" || (echo "Failed to verify Prysm $binary binary" && exit 1)
+ mv "$file" "$binary"
+ chmod +x "$binary"
+}
package() {
- cd "$srcdir/$pkgname"
- mkdir -p "$pkgdir/usr/bin/" "$pkgdir/usr/lib/systemd/system" "$pkgdir/var/lib/prysm/validator"
+ cd "$srcdir"
+ mkdir -p "$pkgdir/usr/bin/"
- for target in beacon-chain validator slasher
+ for target in beacon-chain validator client-stats
do
- cd $target && HOME=/tmp go build -trimpath . && cd ..
-
- install "$srcdir/$pkgname/$target/$target" "$pkgdir/usr/bin/prysm.$target"
+ downloadBinary $target
+ install "$target" "$pkgdir/usr/bin/prysm-$target"
done
- install -Dm644 "$srcdir/prysm-beacon-chain.service" -t "$pkgdir/usr/lib/systemd/system"
- install -Dm644 "$srcdir/prysm-slasher.service" -t "$pkgdir/usr/lib/systemd/system"
- install -Dm644 "$srcdir/prysm-validator@.service" -t "$pkgdir/usr/lib/systemd/system"
- install -Dm 644 "$srcdir/${pkgname}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
-
+ install -Dm644 "prysm-beacon-chain.service" -t "$pkgdir/usr/lib/systemd/user"
+ install -Dm644 "prysm-validator.service" -t "$pkgdir/usr/lib/systemd/user"
+ install -Dm644 "prysm-client-stats.service" -t "$pkgdir/usr/lib/systemd/user"
}
diff --git a/prysm-beacon-chain.service b/prysm-beacon-chain.service
index 6fd8a524e9df..c7d99458bb49 100644
--- a/prysm-beacon-chain.service
+++ b/prysm-beacon-chain.service
@@ -1,32 +1,11 @@
[Unit]
-Description=Prysm beacon-chain client
+Description=Prysm Beacon chain daemon
After=network-online.target
[Service]
DynamicUser=true
-ExecStart=/usr/bin/prysm.beacon-chain --datadir=/var/lib/prysm/beacon-chain
-Restart=always
-StateDirectory=prysm/beacon-chain
-
-NoNewPrivileges=yes
-CapabilityBoundingSet=
-SystemCallArchitectures=native
-SystemCallFilter=@system-service
-
-PrivateDevices=yes
-PrivateUsers=yes
-PrivateTmp=yes
-
-ProtectSystem=strict
-ProtectClock=yes
-ProtectHome=true
-ProtectKernelLogs=yes
-ProtectKernelModules=yes
-ProtectKernelTunables=yes
-
-RestrictNamespaces=yes
-RestrictRealtime=yes
-RestrictSUIDSGID=yes
+ExecStart=/usr/bin/prysm-beacon-chain --accept-terms-of-use
+Restart=on-failure
[Install]
-WantedBy=default.target
+WantedBy=default.target \ No newline at end of file
diff --git a/prysm-client-stats.service b/prysm-client-stats.service
new file mode 100644
index 000000000000..8ab25d1f72e9
--- /dev/null
+++ b/prysm-client-stats.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Prysm Client Stats
+After=network-online.target
+
+[Service]
+ExecStart=/usr/bin/prysm-client-stats
+Restart=on-failure
+
+[Install]
+WantedBy=default.target
diff --git a/prysm-slasher.service b/prysm-slasher.service
deleted file mode 100644
index 15b9107b2759..000000000000
--- a/prysm-slasher.service
+++ /dev/null
@@ -1,33 +0,0 @@
-[Unit]
-Description=Prysm slasher
-After=network-online.target
-
-[Service]
-DynamicUser=true
-ExecStart=/usr/bin/prysm.slasher --datadir=/var/lib/prysm/slasher
-Restart=always
-StateDirectory=prysm/slasher
-
-NoNewPrivileges=yes
-CapabilityBoundingSet=
-SystemCallArchitectures=native
-SystemCallFilter=@system-service
-
-PrivateDevices=yes
-PrivateUsers=yes
-PrivateTmp=yes
-
-ProtectSystem=strict
-ProtectClock=yes
-ProtectHome=true
-ProtectKernelLogs=yes
-ProtectKernelModules=yes
-ProtectKernelTunables=yes
-
-RestrictAddressFamilies=AF_INET AF_INET6
-RestrictNamespaces=yes
-RestrictRealtime=yes
-RestrictSUIDSGID=yes
-
-[Install]
-WantedBy=default.target
diff --git a/prysm-validator.service b/prysm-validator.service
new file mode 100644
index 000000000000..b9f10c823fdc
--- /dev/null
+++ b/prysm-validator.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Prysm validator client
+After=network-online.target
+
+[Service]
+ExecStart=/usr/bin/prysm-validator --accept-terms-of-use --wallet-password-file %h/.eth2validators/prysm-wallet-password
+Restart=on-failure
+
+[Install]
+WantedBy=default.target
diff --git a/prysm-validator@.service b/prysm-validator@.service
deleted file mode 100644
index caec111a2df9..000000000000
--- a/prysm-validator@.service
+++ /dev/null
@@ -1,14 +0,0 @@
-[Unit]
-Description=Prysm validator client %i
-After=network-online.target
-
-[Service]
-User=prysm
-EnvironmentFile=/etc/conf.d/prysm-validator.%i
-ExecStartPre=/usr/bin/mkdir -p /var/lib/prysm/validator/%i/keys /var/lib/prysm/validator/%i/data
-ExecStart=/usr/bin/prysm.validator --keymanager=keystore --keymanageropts='{"passphrase":"${password}","path":"/var/lib/prysm/validator/%i/keys"}' --beacon-rpc-provider=${beacon} --datadir=/var/lib/prysm/validator/%i/data
-Restart=always
-StateDirectory=prysm/validator
-
-[Install]
-WantedBy=default.target
diff --git a/prysm.sysusers b/prysm.sysusers
deleted file mode 100644
index 581bfc36bf3d..000000000000
--- a/prysm.sysusers
+++ /dev/null
@@ -1 +0,0 @@
-u prysm - "prysm beacon/validator user" /var/lib/prysm /sbin/nologin