summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViraaj Basi2023-06-11 02:57:38 +0100
committerViraaj Basi2023-06-11 02:57:38 +0100
commit741561d26a230f038b8d64fefcc82ddb962264bc (patch)
treebf0a0e3c76e7a566a3a0db872db87ad2da6c168c
downloadaur-741561d26a230f038b8d64fefcc82ddb962264bc.tar.gz
creating initial aur package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c367f52eb2f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ps3-disc-dumper-bin
+ pkgdesc = A handy utility to make decrypted PS3 disc dumps
+ pkgver = 3.3.6
+ pkgrel = 1
+ url = https://github.com/13xforever/ps3-disc-dumper
+ arch = x86_64
+ license = MIT
+ depends = glibc
+ depends = zlib
+ depends = gcc-libs
+ options = !strip
+ source = https://github.com/13xforever/ps3-disc-dumper/releases/download/v3.3.6/ps3-disc-dumper_lin64_v3.3.6.zip
+ source = https://github.com/13xforever/ps3-disc-dumper/archive/refs/tags/v3.3.6.zip
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = ps3-disc-dumper-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a5ebc69a788
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Viraaj Basi <viraajbasi@gmail.com>
+pkgname=ps3-disc-dumper-bin
+pkgver=3.3.6
+pkgrel=1
+pkgdesc="A handy utility to make decrypted PS3 disc dumps"
+arch=('x86_64')
+url="https://github.com/13xforever/ps3-disc-dumper"
+license=('MIT')
+depends=('glibc' 'zlib' 'gcc-libs')
+options=('!strip')
+source=("https://github.com/13xforever/${pkgname/-bin/}/releases/download/v${pkgver}/${pkgname/-bin/}_lin64_v${pkgver}.zip"
+ "https://github.com/13xforever/ps3-disc-dumper/archive/refs/tags/v${pkgver}.zip")
+md5sums=('SKIP' 'SKIP')
+
+package() {
+ install -Dm755 "${srcdir}/${pkgname/-bin/}" "${pkgdir}/usr/bin/${pkgname/-bin/}"
+ install -Dm644 "${srcdir}/${pkgname/-bin/}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+