summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-06-12 22:01:06 +0200
committeroli2015-06-12 22:01:06 +0200
commit1c829611aa08a5e271d9ab209960de86b49d3625 (patch)
tree6412b294cf22789c62e249d95509044260028501
downloadaur-1c829611aa08a5e271d9ab209960de86b49d3625.tar.gz
Initial import
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
3 files changed, 60 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..96e3974009b9
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = psani-profi
+ pkgdesc = Program that will teach you touchtyping (czech)
+ pkgver = 3.3.00
+ pkgrel = 2
+ url = http://www.sallyx.org/sally/psani-vsemi-deseti/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = bash
+ depends = xorg-luit
+ source = http://www.sallyx.org/sally/psani-vsemi-deseti/start.php?target=download&file=psani-profi_3.3.00
+ md5sums = 51f3b930ac46a562326cc587704258cf
+
+pkgname = psani-profi
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..96e3974009b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = psani-profi
+ pkgdesc = Program that will teach you touchtyping (czech)
+ pkgver = 3.3.00
+ pkgrel = 2
+ url = http://www.sallyx.org/sally/psani-vsemi-deseti/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = bash
+ depends = xorg-luit
+ source = http://www.sallyx.org/sally/psani-vsemi-deseti/start.php?target=download&file=psani-profi_3.3.00
+ md5sums = 51f3b930ac46a562326cc587704258cf
+
+pkgname = psani-profi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75bde816aea4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=psani-profi
+pkgver=3.3.00
+pkgrel=2
+pkgdesc="Program that will teach you touchtyping (czech)"
+arch=('i686' 'x86_64')
+url="http://www.sallyx.org/sally/psani-vsemi-deseti/"
+license=('GPL')
+depends=('bash' 'xorg-luit')
+source=("http://www.sallyx.org/sally/psani-vsemi-deseti/start.php?target=download&file=${pkgname}_${pkgver}")
+md5sums=('51f3b930ac46a562326cc587704258cf')
+
+build() {
+ cd $srcdir; zcat start.php\?target=download\&file=${pkgname}_${pkgver} | tar xf -
+ cd "$srcdir/${pkgname}_${pkgver}/zdrojaky"
+ ./configure --with-zobraz-test --with-lat-dir=/usr/share --with-prg-dir=/usr/bin --with-man-dir=/usr/share/man
+ make
+ ./configure --with-zobraz-test --with-lat-dir=$pkgdir/usr/share --with-prg-dir=$pkgdir/usr/bin --with-man-dir=$pkgdir/usr/share/man
+}
+
+package() {
+ cd "$srcdir/${pkgname}_${pkgver}/zdrojaky"
+ #./configure --with-zobraz-test --with-lat-dir=$pkgdir/usr/share --with-prg-dir=$pkgdir/usr/bin --with-man-dir=$pkgdir/usr/share/man
+ make install
+ # this is useless - we have pacman
+ rm $pkgdir/usr/bin/${pkgname}-${pkgver}-uninstall.sh
+ sed -i '/LC_ALL/s!\(.*\)luit \(.*\)\(/usr/bin/psani-profi.*\)!\1luit \3!' $pkgdir/usr/bin/psani
+ chown -R root:root $pkgdir/usr/share/psanipb
+}