summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Coffin2017-10-23 19:18:58 -0600
committerMatt Coffin2017-10-23 19:18:58 -0600
commit9490ccc4452df0dbb080af91f395bd0971daa0bc (patch)
tree2449f11dba21f2a5cff96bd681ca3b4dcb5d5f61
downloadaur-9490ccc4452df0dbb080af91f395bd0971daa0bc.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD45
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..884f136133aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = psc-package
+ pkgdesc = A package manager for PureScript based on package sets
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = https://github.com/purescript/psc-package
+ arch = x86_64
+ license = BSD3
+ provides = psc-package
+ source = https://github.com/purescript/psc-package/releases/download/v0.2.4/linux64.tar.gz
+ sha1sums = 6b7e745642d15161c0390abd1b8c709782106ad3
+
+pkgname = psc-package
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1976737233f4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.xz
+linux64.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f473237513b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Matt Coffin <mcoffin13@gmail.com>
+pkgname=psc-package
+pkgver=0.2.4
+pkgrel=1
+epoch=
+pkgdesc="A package manager for PureScript based on package sets"
+arch=('x86_64')
+url="https://github.com/purescript/psc-package"
+license=('BSD3')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=('psc-package')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/purescript/psc-package/releases/download/v$pkgver/linux64.tar.gz")
+noextract=()
+sha1sums=('6b7e745642d15161c0390abd1b8c709782106ad3')
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname"
+}
+
+build() {
+ cd "$pkgname"
+}
+
+check() {
+ cd "$pkgname"
+}
+
+package() {
+ cd "$pkgname"
+ install -D -m 0755 -t "$pkgdir/usr/bin" psc-package
+ if [ -e LICENSE ]; then
+ install -D -m 0644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+ fi
+}