summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Walladge2018-07-02 09:41:58 +0930
committerSamuel Walladge2018-07-02 09:41:58 +0930
commit5ad8b4c229660219360a9f6a59a829a34b684765 (patch)
treef3c647c89e4ba4b684b1fb112090ab490fd31346
downloadaur-5ad8b4c229660219360a9f6a59a829a34b684765.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b81bba2ef925
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pscircle-git
+ pkgdesc = pscircle visualizes Linux processes in a form of radial tree
+ pkgver = 1.0.0.7.g6adff32
+ pkgrel = 1
+ url = https://gitlab.com/mildlyparallel/pscircle
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = meson
+ makedepends = cairo
+ makedepends = libpng
+ makedepends = libx11
+ depends = cairo
+ provides = pscircle
+ conflicts = pscircle
+ source = pscircle-git::git+https://gitlab.com/mildlyparallel/pscircle.git
+ md5sums = SKIP
+
+pkgname = pscircle-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0cbc20dc33c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: swalladge <samuel at swalladge dot id dot au>
+
+pkgname=pscircle-git
+_pkgname=pscircle
+pkgver=1.0.0.7.g6adff32
+pkgrel=1
+pkgdesc="pscircle visualizes Linux processes in a form of radial tree"
+arch=('i686' 'x86_64')
+url="https://gitlab.com/mildlyparallel/pscircle"
+license=('GPL2')
+depends=('cairo')
+makedepends=('meson' 'cairo' 'libpng' 'libx11')
+provides=('pscircle')
+conflicts=('pscircle')
+source=("$pkgname"::'git+https://gitlab.com/mildlyparallel/pscircle.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --tags | sed 's/^v//' | sed 's/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ mkdir -p build
+ cd build
+ meson ..
+ ninja
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 "build/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ # install -Dm644 "examples/${_pkgname}.service" "${pkgdir}/usr/lib/systemd/user/${_pkgname}.service"
+}