summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordakataca2022-11-08 21:02:55 -0500
committerdakataca2022-11-08 21:02:55 -0500
commit17a92963174fe945d50203456e6e0c21afe2712e (patch)
tree4b097abc3707e69286c560ef0075546d1f43aaaa
parentf6a3f9756be1ab172d22b0e343564bf4fce4a25c (diff)
downloadaur-17a92963174fe945d50203456e6e0c21afe2712e.tar.gz
Add prepare() and update gendesk parameters
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD41
-rwxr-xr-x[-rw-r--r--]pseint5
3 files changed, 36 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c506292edbf..3936a470ab01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = pseint
- pkgdesc = Educational tool to learn the fundamentals and development of programming logic
+ pkgdesc = A tool for learning programming basis with a simple spanish pseudocode
pkgver = 20210609
pkgrel = 1
url = http://pseint.sourceforge.net
arch = x86_64
license = GPL2
- depends = libpng12
- depends = glu
depends = gendesk
+ depends = wxwidgets-gtk3
conflicts = pseint-bin
noextract = creator.psz
- source = https://razaoinfo.dl.sourceforge.net/project/pseint/20210609/pseint-l64-20210609.tgz
+ source = pseint-20210609.tar.gz::https://cfhcable.dl.sourceforge.net/project/pseint/20210609/pseint-l64-20210609.tgz
sha256sums = a5df4e147c529e3da509b30dee02791642c32cb3b5bbbc6cd3cd7594f10cb9f4
pkgname = pseint
diff --git a/PKGBUILD b/PKGBUILD
index 6e7d8a8da89e..e72c2674af71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,44 @@
-# Maintainer: dakataca <danieldakataca@gmail.com>
+# Maintainer: dakataca <🐬danieldakataca@gmail.com>
# Contributor: Cristophero <cristophero.alvarado@gmail.com>
pkgname=pseint
pkgver=20210609
pkgrel=1
-pkgdesc="Educational tool to learn the fundamentals and development of programming logic"
+pkgdesc="A tool for learning programming basis with a simple spanish pseudocode"
+comment="Educational tool to learn the fundamentals and development of programming logic"
arch=('x86_64')
url='http://pseint.sourceforge.net'
license=('GPL2')
conflicts=('pseint-bin')
-depends=('libpng12' 'glu' 'gendesk')
+depends=('gendesk' 'wxwidgets-gtk3')
noextract=(creator.psz)
-source=(https://razaoinfo.dl.sourceforge.net/project/pseint/${pkgver}/pseint-l64-${pkgver}.tgz)
+source=("$pkgname-$pkgver.tar.gz::https://cfhcable.dl.sourceforge.net/project/${pkgname}/${pkgver}/${pkgname}-l64-${pkgver}.tgz")
sha256sums=('a5df4e147c529e3da509b30dee02791642c32cb3b5bbbc6cd3cd7594f10cb9f4') # 'makepkg -g' para generarlo.
-package () {
+prepare(){
+ gendesk -f -n \
+ --pkgname="${pkgname}" \
+ --pkgdesc="${pkgdesc}" \
+ --name="${pkgname}" \
+ --genericname="${pkgname}" \
+ --comment="${comment}" \
+ --exec="${pkgname}" \
+ --path="/opt/${pkgname}" \
+ --icon="${pkgname}" \
+ --categories='Development,Education'
+}
- mkdir -p ${pkgdir}/opt/
+package(){
+ install -Dvm644 "${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dvm644 "${srcdir}/${pkgname}/imgs/icon.icns" "${pkgdir}/usr/share/pixmaps/${pkgname}.icns"
+ install -Dvm755 "../${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
cp -r ${srcdir}/${pkgname}/ ${pkgdir}/opt/
-
- gendesk -n -f --exec='pseint %u' ../PKGBUILD
- install -Dm755 "../${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 "${srcdir}/${pkgname}/imgs/icon.icns" "${pkgdir}/usr/share/pixmaps/${pkgname}.icns"
- install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
}
+
+## Test:
+# rm -rf pseint-{20210609.tar.gz,l64-20210609.tgz,20210609-1.src.tar.gz} src/ pkg/
+## References
+
+# https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=densify
+# https://wiki.archlinux.org/title/Desktop_entries#How_to_use
+# https://sourceforge.net/projects/pseint/files/
+# https://sourceforge.net/projects/pseint/files/20210609/pseint-l64-20210609.tgz/download
diff --git a/pseint b/pseint
index 96f177dcd505..4d52a033506a 100644..100755
--- a/pseint
+++ b/pseint
@@ -1,2 +1,3 @@
-#!/usr/bin/env sh
-/opt/pseint/wxPSeInt
+#!/usr/bin/env bash
+#/opt/pseint/wxPSeInt
+/opt/pseint