summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominic Zimmer2017-05-31 09:24:04 +0000
committerDominic Zimmer2017-05-31 09:25:03 +0000
commit80fa76bc558b33e28130df35af959a8293b7ca7e (patch)
treeed979b0c485f506a51939941985846e21847f90d
downloadaur-80fa76bc558b33e28130df35af959a8293b7ca7e.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
-rw-r--r--executable2
-rwxr-xr-xpseucoco.install6
4 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13a60a9517ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pseucoco
+ pkgdesc = A Pseuco compiler written in Java
+ pkgver = 2.3
+ pkgrel = 1
+ url = https://liebe.cs.uni-saarland.de/gitlab/pseuco/pseuco-java-compiler
+ install = pseucoco.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gradle
+ depends = java-runtime
+ depends = sudo
+ provides = pseucoco
+ conflicts = pseucoco
+ source = pseucoco::git+https://liebe.cs.uni-saarland.de/gitlab/pseuco/pseuco-java-compiler.git
+ md5sums = SKIP
+
+pkgname = pseucoco
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe6395134d62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+_pkgname=pseucoco
+pkgname="${_pkgname}"
+pkgver=2.3
+pkgrel=1
+pkgdesc="A Pseuco compiler written in Java"
+arch=("i686" "x86_64")
+url="https://liebe.cs.uni-saarland.de/gitlab/pseuco/pseuco-java-compiler"
+license=('GPL')
+depends=("java-runtime" "sudo")
+makedepends=("gradle")
+
+provides=("pseucoco")
+conflicts=("pseucoco")
+install="${_pkgname}.install"
+source=("pseucoco::git+${url}.git")
+md5sums=("SKIP")
+
+build() {
+ cd pseucoco
+ gradle jar
+}
+
+package() {
+ mkdir -p $pkgdir/usr/share/${_pkgname}/include
+ mkdir -p $pkgdir/usr/bin
+ cat ../executable > $pkgdir/usr/bin/pseucoco
+ chmod +x $pkgdir/usr/bin/pseucoco
+ cd pseucoco
+ cp -r include build/libs/pseucoco-2.3.jar $pkgdir/usr/share/${_pkgname}
+ echo "package"
+}
diff --git a/executable b/executable
new file mode 100644
index 000000000000..b94f6ca6cc1f
--- /dev/null
+++ b/executable
@@ -0,0 +1,2 @@
+#!/bin/bash
+sudo java -jar /usr/share/pseucoco/pseucoco-2.3.jar $@
diff --git a/pseucoco.install b/pseucoco.install
new file mode 100755
index 000000000000..e1f50f8d8cbd
--- /dev/null
+++ b/pseucoco.install
@@ -0,0 +1,6 @@
+#!/bin/bash
+post_install() {
+ echo "This program currently requires sudo access."
+ echo "That is because the pseuco compiler requires write access on the files it creates in /usr/share/pseucoco/include."
+ echo "Hopefully this will be fixed in the future."
+}