summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWu Zhenyu2023-10-28 17:03:48 +0800
committerWu Zhenyu2023-10-28 17:03:48 +0800
commit7990a33642824fae15f5806fbd42b2a272b41e29 (patch)
treee7738cf3c60995a6cc4ef305d9fb7c5987d479c0
parent0ccceb174f28ec9e79396a31beac7c2a61d04ff5 (diff)
downloadaur-7990a33642824fae15f5806fbd42b2a272b41e29.tar.gz
:tada: Initial
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD13
3 files changed, 26 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17bcae5b3673
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pseudo-git
+ pkgdesc = an analogue to sudo
+ pkgver = r420.f9f1278
+ pkgrel = 1
+ url = https://git.yoctoproject.org/pseudo
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = aarch64
+ license = LGPL
+ source = git+https://git.yoctoproject.org/pseudo
+ sha256sums = SKIP
+
+pkgname = pseudo-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4b62e7679d6f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/*
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
+!/*.install
+!/nvchecker.toml
diff --git a/PKGBUILD b/PKGBUILD
index cb13a7aa68eb..e8f3a18873a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,12 @@
# Maintainer: Wu Zhenyu <wuzhenyu@ustc.edu>
_pkgname=pseudo
pkgname=$_pkgname-git
-pkgver=0.0.1
pkgrel=1
-pkgdesc=""
-arch=(any)
-url=https://github.com/Freed-Wu/$_pkgname
-license=(GPL3)
-makedepends=(git)
+pkgver=r420.f9f1278
+pkgdesc="an analogue to sudo"
+arch=(i686 x86_64 arm aarch64)
+url=https://git.yoctoproject.org/$_pkgname
+license=(LGPL)
source=("git+$url")
sha256sums=(SKIP)
@@ -26,5 +25,5 @@ build() {
package() {
cd "$_pkgname" || return 1
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" LIBDIR=/usr/lib install
}