summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneeshy2023-11-12 22:29:14 -0500
committerneeshy2023-11-12 22:35:34 -0500
commitcb07584711f47a9f69742fbfad2923c4389d1a0b (patch)
tree7005d8423c983e92c29e5d53c7727d8f1f811d2d
downloadaur-cb07584711f47a9f69742fbfad2923c4389d1a0b.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD20
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5609cdaacb0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = psf-unifont
+ pkgdesc = GNU Unifont Glyphs (PSF version)
+ pkgver = 15.1.04
+ pkgrel = 1
+ url = https://unifoundry.com/unifont/index.html
+ arch = any
+ license = GPL2
+ license = custom:OFL
+ source = https://ftp.gnu.org/gnu/unifont/unifont-15.1.04/Unifont-APL8x16-15.1.04.psf.gz
+ source = https://ftp.gnu.org/gnu/unifont/unifont-15.1.04/Unifont-APL8x16-15.1.04.psf.gz.sig
+ source = https://unifoundry.com/LICENSE.txt
+ validpgpkeys = 95D2E9AB8740D8046387FD151A09227B1F435A33
+ sha256sums = f6845bb729ac22845398925b93932469b32a25cf9450c071683808b7b8db6fd6
+ sha256sums = SKIP
+ sha256sums = 1e74cb82bf476843e97c2596297b04219b1a7e51f7238944a8c031cb9401fa87
+
+pkgname = psf-unifont
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a7c811caf97
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: neeshy <neeshy@tfwno.gf>
+pkgname=psf-unifont
+pkgver=15.1.04
+pkgrel=1
+pkgdesc="GNU Unifont Glyphs (PSF version)"
+arch=('any')
+url="https://unifoundry.com/unifont/index.html"
+license=('GPL2' 'custom:OFL')
+source=("https://ftp.gnu.org/gnu/unifont/unifont-$pkgver/Unifont-APL8x16-$pkgver.psf.gz"{,.sig}
+ "https://unifoundry.com/LICENSE.txt")
+sha256sums=('f6845bb729ac22845398925b93932469b32a25cf9450c071683808b7b8db6fd6'
+ 'SKIP'
+ '1e74cb82bf476843e97c2596297b04219b1a7e51f7238944a8c031cb9401fa87')
+validpgpkeys=('95D2E9AB8740D8046387FD151A09227B1F435A33') # Paul Hardy <unifoundry@unifoundry.com>
+
+package() {
+ cd "$srcdir"
+ install -Dm644 "Unifont-APL8x16-$pkgver.psf.gz" "$pkgdir/usr/share/kbd/consolefonts/Unifont-APL8x16.psf.gz"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}