summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Sampson2015-10-13 18:30:04 +1100
committerMike Sampson2015-10-13 18:30:04 +1100
commit1dc6dcf7cd4cfa4f06544e97316709d6d2162eef (patch)
treee7e98c11d9fc073ac7a95ff9477e1e515db9df6f
parentdda05ae24ad22a294e4413c87b3f6f452b904b90 (diff)
downloadaur-1dc6dcf7cd4cfa4f06544e97316709d6d2162eef.tar.gz
Switch from build() to package()
Also moved from googlecode to github.
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e3a60cc6ce8..1077f8cd81eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
# Contributor: Nathan Owe. <ndowens04+AUR@gmail.com>
-# Maintainer: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Maintainer: Mike Sampson <mike@sambodata.com>
pkgname=psgrep
pkgver=1.0.6
-pkgrel=1
+pkgrel=2
pkgdesc="Process list search thru grep"
arch=('i686' 'x86_64')
-url="http://code.google.com/p/psgrep/"
+url="https://github.com/jvz/psgrep"
license=('GPL3')
-source=(http://psgrep.googlecode.com/files/${pkgname}-${pkgver}.tar.bz2)
-md5sums=('2d74c8746950c2b4efe5eac96303bf09')
+_commit=936fc18be10ebae84eff73c8fb7dc77a93b3d2cf
+source=(https://github.com/jvz/${pkgname}/archive/${_commit}.zip)
+md5sums=('d2cee26386237dbd8046dbe5599a9f53')
-build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+package() {
+ cd ${srcdir}/${pkgname}-${_commit}
install -Dm755 psgrep ${pkgdir}/usr/bin/psgrep
install -Dm644 psgrep.1 ${pkgdir}/usr/share/man/man1/psgrep.1
}