summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2015-06-04 10:55:01 +0200
committerHyacinthe Cartiaux2015-06-09 10:20:23 +0200
commit2e24af5276bb3ae2b3107c633a361a4d34d6a82c (patch)
tree7164eacefd988f8cf8ffb4eac3db4ad59b045ed2
downloadaur-2e24af5276bb3ae2b3107c633a361a4d34d6a82c.tar.gz
[psi-qt5-git] Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD38
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0677676364c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = psi-qt5-git
+ pkgdesc = A jabber client. GIT version
+ pkgver = 0.16_dev_20150604
+ pkgrel = 1
+ url = http://psi-im.org/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = qconf-git
+ depends = qt5-base
+ depends = qca-qt5
+ depends = qt5-x11extras
+ depends = enchant
+ depends = libxss
+ depends = openssl
+ depends = dbus
+ depends = zlib
+ provides = psi-git
+ conflicts = psi
+ conflicts = psi-git
+ source = git+https://github.com/psi-im/psi.git
+ md5sums = SKIP
+
+pkgname = psi-qt5-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1d585f2b510
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
+pkgname=psi-qt5-git
+pkgver=0.16_dev_20150604
+pkgrel=1
+pkgdesc="A jabber client. GIT version"
+arch=('i686' 'x86_64')
+url="http://psi-im.org/"
+license=('GPL2')
+depends=('qt5-base' 'qca-qt5' 'qt5-x11extras' 'enchant' 'libxss' 'openssl' 'dbus' 'zlib')
+makedepends=('git' 'qconf-git')
+conflicts=('psi' 'psi-git')
+provides=('psi-git')
+source=(git+https://github.com/psi-im/psi.git)
+md5sums=('SKIP')
+
+pkgver() {
+echo 0.16_dev_$(date +"%Y%m%d")
+}
+
+build() {
+ cd $srcdir/psi
+
+ git submodule init
+ git submodule update
+
+ qconf
+ export QTDIR=/usr/lib/qt5
+ ./configure --prefix=/usr
+ qmake-qt5 psi.pro
+
+}
+
+package() {
+ cd $srcdir/psi
+
+ make INSTALL_ROOT="$pkgdir" install
+}
+