summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2016-05-19 15:57:27 +0200
committerHyacinthe Cartiaux2016-05-19 16:03:49 +0200
commit31ce1d25984675f97b380b856accdd7334816fcb (patch)
treed1d72408ecc6e5c79c41a1c0afa271104832ee8f
parent3e47dffadc9803991a96c45f491e8484d041556d (diff)
downloadaur-31ce1d25984675f97b380b856accdd7334816fcb.tar.gz
Patch the configure file (minizip, https://github.com/psi-plus/psi-plus-snapshots/issues/14)
Add the configure diff file
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--configure.diff13
3 files changed, 23 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2b94639ed49..ccb5251564b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Oct 25 16:07:57 UTC 2015
+# Thu May 19 13:46:53 UTC 2016
pkgbase = psi-git
pkgdesc = A jabber client. GIT version
- pkgver = 0.16_dev_20151025
+ pkgver = 0.16_dev_20160519
pkgrel = 1
url = http://psi-im.org/
install = psi-git.install
@@ -23,7 +23,9 @@ pkgbase = psi-git
replaces = psi
replaces = psi-qt5-git
source = git+https://github.com/psi-im/psi.git
+ source = configure.diff
md5sums = SKIP
+ md5sums = a51eabeb51bb81262dfe15eec5c4b117
pkgname = psi-git
diff --git a/PKGBUILD b/PKGBUILD
index e96fa3972ac1..ca1576b3b2da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
pkgname=psi-git
-pkgver=0.16_dev_20151025
+pkgver=0.16_dev_20160519
pkgrel=1
pkgdesc="A jabber client. GIT version"
arch=('i686' 'x86_64')
@@ -11,8 +11,10 @@ makedepends=('git' 'qconf-git')
replaces=('psi' 'psi-qt5-git')
conflicts=('psi' 'psi-qt5-git')
install=psi-git.install
-source=('git+https://github.com/psi-im/psi.git')
-md5sums=('SKIP')
+source=('git+https://github.com/psi-im/psi.git'
+ 'configure.diff')
+md5sums=('SKIP'
+ 'a51eabeb51bb81262dfe15eec5c4b117')
pkgver() {
echo 0.16_dev_$(date +"%Y%m%d")
@@ -25,6 +27,7 @@ build() {
git submodule update
qconf
+ patch -p0 < "$srcdir"/configure.diff
./configure --prefix=/usr \
--libdir=/usr/lib \
--qtdir="/usr/lib/qt" \
diff --git a/configure.diff b/configure.diff
new file mode 100644
index 000000000000..9b452fe3001f
--- /dev/null
+++ b/configure.diff
@@ -0,0 +1,13 @@
+--- configure.orig 2016-05-19 15:42:51.790642988 +0200
++++ configure 2016-05-19 15:42:46.663840473 +0200
+@@ -1082,6 +1082,9 @@
+ }
+ conf->addLib(libs);
+
++ conf->addExtra("CONFIG += psi-minizip");
++ return true;
++
+ #ifdef Q_OS_WIN
+ // HACK: on windows, always use psi's bundled minizip
+ conf->addExtra("CONFIG += psi-minizip");
+