summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2017-05-05 11:43:51 +0200
committerHyacinthe Cartiaux2017-05-05 11:43:51 +0200
commit408cfc88b852a04175717291f8b4489201bbde46 (patch)
tree0ba291bd55d67511d38904e8ab2202ad1977a049
parent9b5ac9dd0c2aaa0c028ca86eb44a59d0d4379aac (diff)
downloadaur-408cfc88b852a04175717291f8b4489201bbde46.tar.gz
Fix the compilation issue
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD28
-rw-r--r--configure.diff13
3 files changed, 18 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9aece082597..ac5559f87642 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu May 19 14:01:43 UTC 2016
+# Fri May 5 09:43:26 UTC 2017
pkgbase = psi-git
pkgdesc = A jabber client. GIT version
- pkgver = 0.16_dev_20160519
+ pkgver = 0.16_dev_20170505
pkgrel = 1
url = http://psi-im.org/
arch = i686
@@ -22,9 +22,7 @@ pkgbase = psi-git
replaces = psi
replaces = psi-qt5-git
source = git+https://github.com/psi-im/psi.git
- source = configure.diff
md5sums = SKIP
- md5sums = a51eabeb51bb81262dfe15eec5c4b117
pkgname = psi-git
diff --git a/PKGBUILD b/PKGBUILD
index 78122d65c37a..5668294be42b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
pkgname=psi-git
-pkgver=0.16_dev_20160519
+pkgver=0.16_dev_20170505
pkgrel=1
pkgdesc="A jabber client. GIT version"
arch=('i686' 'x86_64')
@@ -10,28 +10,32 @@ depends=('qca-qt5' 'qt5-x11extras' 'aspell' 'libxss' 'minizip' 'desktop-file-uti
makedepends=('git' 'qconf-git')
replaces=('psi' 'psi-qt5-git')
conflicts=('psi' 'psi-qt5-git')
-source=('git+https://github.com/psi-im/psi.git'
- 'configure.diff')
-md5sums=('SKIP'
- 'a51eabeb51bb81262dfe15eec5c4b117')
+source=('git+https://github.com/psi-im/psi.git')
+md5sums=('SKIP')
pkgver() {
echo 0.16_dev_$(date +"%Y%m%d")
}
-build() {
+prepare() {
+
cd $srcdir/psi
git submodule init
git submodule update
+}
+
+build() {
+
+ cd $srcdir/psi
+
qconf
- patch -p0 < "$srcdir"/configure.diff
- ./configure --prefix=/usr \
- --libdir=/usr/lib \
- --qtdir="/usr/lib/qt" \
- --disable-enchant
- # qmake-qt5 PREFIX=/usr psi.pro
+
+ ./configure --prefix=/usr \
+ --libdir=/usr/lib \
+ --disable-enchant \
+ --qtselect=5
make
}
diff --git a/configure.diff b/configure.diff
deleted file mode 100644
index 9b452fe3001f..000000000000
--- a/configure.diff
+++ /dev/null
@@ -1,13 +0,0 @@
---- configure.orig 2016-05-19 15:42:51.790642988 +0200
-+++ configure 2016-05-19 15:42:46.663840473 +0200
-@@ -1082,6 +1082,9 @@
- }
- conf->addLib(libs);
-
-+ conf->addExtra("CONFIG += psi-minizip");
-+ return true;
-+
- #ifdef Q_OS_WIN
- // HACK: on windows, always use psi's bundled minizip
- conf->addExtra("CONFIG += psi-minizip");
-