summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Down2020-04-29 22:02:39 +0100
committerChris Down2020-04-29 22:02:39 +0100
commitc2c47e2e1ebfb769cecd79e61b217bc3fb754729 (patch)
treeeae4d2b5f6c9b3fccd62c99f74281f1b15542034
downloadaur-c2c47e2e1ebfb769cecd79e61b217bc3fb754729.tar.gz
Initial upload: psi-notify-git 0.3.r23.g7d356b1-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9dcaaba3b4dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = psi-notify-git
+ pkgdesc = Minimalistic PSI notifier using libnotify (git version)
+ pkgver = 0.3.r23.g7d356b1
+ pkgrel = 1
+ url = https://github.com/cdown/psi-notify
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = libnotify
+ provides = psi-notify
+ conflicts = psi-notify
+ source = git://github.com/cdown/psi-notify.git
+ md5sums = SKIP
+
+pkgname = psi-notify-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a05fd8eddf3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Chris Down <chris@chrisdown.name>
+
+pkgname=psi-notify-git
+_gitname=psi-notify
+pkgver=0.3.r23.g7d356b1
+pkgrel=1
+pkgdesc='Minimalistic PSI notifier using libnotify (git version)'
+url="https://github.com/cdown/psi-notify"
+license=('MIT')
+arch=('any')
+depends=(libnotify)
+provides=(psi-notify)
+conflicts=(psi-notify)
+makedepends=(git)
+source=(git://github.com/cdown/psi-notify.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+build() {
+ cd -- "$_gitname"
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/bin "$pkgdir"/usr/lib/systemd/user
+ cp -a "${srcdir?}/$_gitname"/psi-notify "$pkgdir"/usr/bin
+ cp -a "${srcdir?}/$_gitname"/psi-notify.service \
+ "$pkgdir"/usr/lib/systemd/user
+}