summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIru Cai2018-08-07 13:17:00 +0800
committerIru Cai2018-08-07 13:17:00 +0800
commitcc8112378bcad6a9d002ff607fb2359ad122c885 (patch)
treea637471fc137fe4627d02b7ed58100337e3e43fe
parent92b7047acd92d456e2d228a77b159d8e4712e942 (diff)
downloadaur-cc8112378bcad6a9d002ff607fb2359ad122c885.tar.gz
1.3.400, OTR fix
-rw-r--r--PKGBUILD9
-rw-r--r--otr-fix.patch23
2 files changed, 29 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f1e8857c366a..2701513de4da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Alexey D. <lq07829icatm@rambler.ru>
pkgname=psi-plus
-pkgver=1.3.398
+pkgver=1.3.400
pkgrel=1
pkgdesc="Psi+ is a powerful XMPP client (Qt, C++) designed for the XMPP power users (with all plugins)"
url="https://psi-plus.com"
@@ -15,12 +15,15 @@ depends=('qt5-base' 'qt5-webengine' 'qt5-multimedia' 'qt5-x11extras' 'qca-qt5'
'libidn' 'libxss' 'qt5-svg' 'hunspell' 'qtkeychain'
'libaxolotl-c-git' 'libotr' 'tidy')
makedepends=('patch' 'cmake')
-source=("https://github.com/psi-plus/psi-plus-snapshots/archive/${pkgver}.tar.gz")
-sha256sums=('c883cabcfec482e1fbf0cfaf0910bb6e976be267dbab3de66b0a7cb2dd22b34c')
+source=("https://github.com/psi-plus/psi-plus-snapshots/archive/${pkgver}.tar.gz" "otr-fix.patch")
+sha256sums=('4c6d172b4d3e4475bf129531b6f4b925951a25c3a6e5f6ff6c8172733157905b'
+ 'e1a7dfdf2d7d9cd7154e2a0fa5516ab9aea2d4a25201a85a2baf80c19c60e55b')
build() {
cd psi-plus-snapshots-${pkgver}
+ # https://github.com/psi-im/plugins/issues/43
+ patch -p0 -i "${srcdir}/otr-fix.patch"
mkdir -p build
cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release \
diff --git a/otr-fix.patch b/otr-fix.patch
new file mode 100644
index 000000000000..68eaf8e09ed8
--- /dev/null
+++ b/otr-fix.patch
@@ -0,0 +1,23 @@
+--- src/plugins/generic/otrplugin/src/psiotrplugin.cpp.orig 2018-08-07 10:34:08.066936689 +0800
++++ src/plugins/generic/otrplugin/src/psiotrplugin.cpp 2018-08-07 10:34:27.536937111 +0800
+@@ -589,20 +589,6 @@
+ xml.removeChild(htmlElement);
+ }
+
+- if (m_onlineUsers[account][contact]->encrypted()) {
+- if (xml.attribute("to").contains("/")) {
+- // if not a bare jid
+- htmlElement = xml.ownerDocument().createElementNS("urn:xmpp:hints" ,"no-copy");
+- xml.appendChild(htmlElement);
+- }
+-
+- htmlElement = xml.ownerDocument().createElementNS("urn:xmpp:hints", "no-permanent-store");
+- xml.appendChild(htmlElement);
+-
+- htmlElement = xml.ownerDocument().createElementNS("urn:xmpp:carbons:2", "private");
+- xml.appendChild(htmlElement);
+- }
+-
+ return false;
+ }
+