summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIru Cai2021-03-31 21:37:34 +0800
committerIru Cai2021-03-31 21:37:56 +0800
commitceb0f5bdc04db7ae5f6f740bba29757d1f3cf606 (patch)
treec3e0bbc6d7262898add3558930b6dd1b2ff01672
parentcae85c7378d3f58038e40de99d6a177ff1ed6bad (diff)
downloadaur-ceb0f5bdc04db7ae5f6f740bba29757d1f3cf606.tar.gz
1.5.1484
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dbe3bc3a59e8..a63eecf42702 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = psi-plus
pkgdesc = Psi+ is a powerful XMPP client (Qt, C++) designed for the XMPP power users (with all plugins)
- pkgver = 1.4.1028
+ pkgver = 1.5.1484
pkgrel = 1
url = https://psi-plus.com
arch = x86_64
license = GPL2
makedepends = patch
makedepends = cmake
- depends = qt5-base
+ makedepends = usrsctp-git
depends = qt5-webengine
depends = qt5-multimedia
depends = qt5-x11extras
@@ -20,10 +20,9 @@ pkgbase = psi-plus
depends = libsignal-protocol-c
depends = libotr
depends = tidy
- source = https://github.com/psi-plus/psi-plus-snapshots/archive/1.4.1028.tar.gz
- source = otr-fix.patch
- sha256sums = 9c3cd36a54abd6a4ec5c8602bffdc007fa16b490221ccde98818b8536e19a017
- sha256sums = e1a7dfdf2d7d9cd7154e2a0fa5516ab9aea2d4a25201a85a2baf80c19c60e55b
+ depends = http-parser
+ source = https://github.com/psi-plus/psi-plus-snapshots/archive/1.5.1484.tar.gz
+ sha256sums = 631652c66904ed8b6deca557370c3708a8862931633f7676070326b0f0eda444
pkgname = psi-plus
diff --git a/PKGBUILD b/PKGBUILD
index 0a3dd0614278..3e24786c370e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,25 +5,23 @@
# Contributor: Alexey D. <lq07829icatm@rambler.ru>
pkgname=psi-plus
-pkgver=1.4.1028
+pkgver=1.5.1484
pkgrel=1
pkgdesc="Psi+ is a powerful XMPP client (Qt, C++) designed for the XMPP power users (with all plugins)"
url="https://psi-plus.com"
license=('GPL2')
arch=('x86_64')
-depends=('qt5-base' 'qt5-webengine' 'qt5-multimedia' 'qt5-x11extras' 'qca'
+depends=('qt5-webengine' 'qt5-multimedia' 'qt5-x11extras' 'qca'
'libidn' 'libxss' 'qt5-svg' 'hunspell' 'qtkeychain'
- 'libsignal-protocol-c' 'libotr' 'tidy')
-makedepends=('patch' 'cmake')
-source=("https://github.com/psi-plus/psi-plus-snapshots/archive/${pkgver}.tar.gz" "otr-fix.patch")
-sha256sums=('9c3cd36a54abd6a4ec5c8602bffdc007fa16b490221ccde98818b8536e19a017'
- 'e1a7dfdf2d7d9cd7154e2a0fa5516ab9aea2d4a25201a85a2baf80c19c60e55b')
-
+ 'libsignal-protocol-c' 'libotr' 'tidy' 'http-parser')
+makedepends=('patch' 'cmake' 'usrsctp-git')
+source=("https://github.com/psi-plus/psi-plus-snapshots/archive/${pkgver}.tar.gz")
+sha256sums=('631652c66904ed8b6deca557370c3708a8862931633f7676070326b0f0eda444')
build() {
cd psi-plus-snapshots-${pkgver}
# https://github.com/psi-im/plugins/issues/43
- patch -p0 -i "${srcdir}/otr-fix.patch"
+ # patch -p0 -i "${srcdir}/otr-fix.patch"
mkdir -p build
cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release \