summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsirlucjan2018-01-15 18:51:10 +0100
committersirlucjan2018-01-15 18:51:10 +0100
commit2fa371ac8633c538f3b5f916f694f268acf0fef1 (patch)
treee7f45e74edb02dcaa993da4eee2913936285d891
parentbc3ee431ca26d6294810636a514c50985540bd23 (diff)
downloadaur-2fa371ac8633c538f3b5f916f694f268acf0fef1.tar.gz
Drop some depends
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
-rw-r--r--no-qca-qt4.patch36
3 files changed, 8 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ece299eba9b..d8725d10a330 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = psi-plus-git
pkgdesc = Psi+ is a powerful Jabber client (Qt, C++) designed for the Jabber power users (built with Qt 5.x)
pkgver = 1.2.161.1.gf3b641d3
- pkgrel = 1
+ pkgrel = 2
url = http://psi-plus.com
arch = x86_64
license = GPL2
@@ -9,12 +9,11 @@ pkgbase = psi-plus-git
makedepends = patch
makedepends = cmake
depends = qt5-base
- depends = qt5-webkit
+ depends = qt5-webengine
depends = qt5-multimedia
depends = qt5-x11extras
depends = qca-qt5
depends = libidn
- depends = aspell
depends = libxss
depends = qt5-svg
depends = hunspell
@@ -24,15 +23,10 @@ pkgbase = psi-plus-git
conflicts = psi-plus
conflicts = psi-plus-qt5-git
conflicts = psi-plus-webkit-qt5-git
- conflicts = psi-plus-webkit-git
source = git://github.com/psi-plus/psi-plus-snapshots
- source = git://github.com/psi-plus/main.git
source = join.patch
- source = no-qca-qt4.patch
- sha256sums = SKIP
sha256sums = SKIP
sha256sums = ea25a58c7efe25979b8d257598608187380e8f35ace25e96cab9c357dcdbc974
- sha256sums = a6ea9a62100b6990b8a6c8590a6d0e9df095b99b6527bb5490a7fd3f6929ac23
pkgname = psi-plus-git
diff --git a/PKGBUILD b/PKGBUILD
index 442a6aa79466..4b5a26859579 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,24 +5,20 @@
pkgname=psi-plus-git
pkgver=1.2.161.1.gf3b641d3
-pkgrel=1
+pkgrel=2
pkgdesc="Psi+ is a powerful Jabber client (Qt, C++) designed for the Jabber power users (built with Qt 5.x)"
url="http://psi-plus.com"
license=('GPL2')
arch=('x86_64')
-depends=('qt5-base' 'qt5-webkit' 'qt5-multimedia' 'qt5-x11extras' 'qca-qt5'
- 'libidn' 'aspell' 'libxss' 'qt5-svg' 'hunspell' 'qtkeychain')
+depends=('qt5-base' 'qt5-webengine' 'qt5-multimedia' 'qt5-x11extras' 'qca-qt5'
+ 'libidn' 'libxss' 'qt5-svg' 'hunspell' 'qtkeychain')
makedepends=('git' 'patch' 'cmake')
provides=("psi-plus=$pkgver" "psi-plus-qt5-git=$pkgver")
-conflicts=('psi-plus' 'psi-plus-qt5-git' 'psi-plus-webkit-qt5-git' 'psi-plus-webkit-git')
+conflicts=('psi-plus' 'psi-plus-qt5-git' 'psi-plus-webkit-qt5-git')
source=("git://github.com/psi-plus/psi-plus-snapshots"
- "git://github.com/psi-plus/main.git"
- 'join.patch'
- 'no-qca-qt4.patch')
+ 'join.patch')
sha256sums=('SKIP'
- 'SKIP'
- 'ea25a58c7efe25979b8d257598608187380e8f35ace25e96cab9c357dcdbc974'
- 'a6ea9a62100b6990b8a6c8590a6d0e9df095b99b6527bb5490a7fd3f6929ac23')
+ 'ea25a58c7efe25979b8d257598608187380e8f35ace25e96cab9c357dcdbc974')
pkgver() {
@@ -33,7 +29,6 @@ pkgver() {
prepare() {
cd psi-plus-snapshots
patch -p1 <"$srcdir"/join.patch
- patch -p1 <"$srcdir"/no-qca-qt4.patch
}
build() {
@@ -48,7 +43,4 @@ package() {
cd psi-plus-snapshots/build
make DESTDIR="$pkgdir" install
-
- # install -dm755 "$pkgdir/usr/include/psi-plus/plugins"
- # install -m644 src/plugins/include/*.h "$pkgdir/usr/include/psi-plus/plugins"
}
diff --git a/no-qca-qt4.patch b/no-qca-qt4.patch
deleted file mode 100644
index 15a5c6129bc3..000000000000
--- a/no-qca-qt4.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From f3372d84595d10b757de4568399707bc721f6850 Mon Sep 17 00:00:00 2001
-From: sirlucjan <lucjan.lucjanov@gmail.com>
-Date: Sun, 7 Jan 2018 21:04:37 +0100
-Subject: [PATCH] Update cmakelist.txt
-
----
- iris/CMakeLists.txt | 2 +-
- src/CMakeLists.txt | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/iris/CMakeLists.txt b/iris/CMakeLists.txt
-index 50228489..85dcec60 100644
---- a/iris/CMakeLists.txt
-+++ b/iris/CMakeLists.txt
-@@ -39,7 +39,7 @@ if(USE_QJDNS)
- add_definitions(-DNEED_JDNS)
- endif()
-
--find_package(Qca REQUIRED)
-+find_package(Qca-qt5 REQUIRED)
- set(QCA_INCLUDES ${Qca_INCLUDE_DIR})
- set(qca_LIB ${Qca_LIBRARY})
-
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 1f78cd05..57c73c4c 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -73,7 +73,7 @@ if(APPLE)
- list(APPEND EXTRA_LDFLAGS ${SPARKLE_LIBRARY} "-framework Carbon" "-framework AppKit" "-framework IOKit" "-framework CoreAudio" "-framework AudioToolbox")
- endif()
-
--find_package( Qca REQUIRED )
-+find_package( Qca-qt5 REQUIRED )
-
- if(LINUX)
- find_package(X11 REQUIRED)