summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2020-11-29 15:04:41 +0100
committerPiotr Gorski2020-11-29 15:04:41 +0100
commit307fdc7e4d3ecb1932f66744d917d6f123a6b342 (patch)
treea05ad0585d927a7852fbf443b517c18d5b80d850
parentb6e0a28b15a0d1327a1b4ebf45ce607ba900e4ea (diff)
downloadaur-307fdc7e4d3ecb1932f66744d917d6f123a6b342.tar.gz
Update build()
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e27eb29ced2b..fc17796a5b05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = psi-plus-git
pkgdesc = Psi+ is a powerful XMPP client (Qt, C++) designed for the XMPP power users (built with Qt 5.x)
- pkgver = 1.4.1399.r1151.g2170e90
+ pkgver = 1.4.1555.r1151.g2170e90
pkgrel = 1
url = https://psi-plus.com
arch = x86_64
@@ -12,15 +12,14 @@ pkgbase = psi-plus-git
depends = qt5-webengine
depends = qt5-multimedia
depends = qt5-x11extras
- depends = qca-qt5
depends = libidn
depends = libxss
depends = qt5-svg
depends = hunspell
depends = qtkeychain
depends = http-parser
- provides = psi-plus=1.4.1399.r1151.g2170e90
- provides = psi-plus-qt5-git=1.4.1399.r1151.g2170e90
+ provides = psi-plus=1.4.1555.r1151.g2170e90
+ provides = psi-plus-qt5-git=1.4.1555.r1151.g2170e90
conflicts = psi-plus
conflicts = psi-plus-qt5-git
conflicts = psi-plus-webkit-qt5-git
diff --git a/PKGBUILD b/PKGBUILD
index 749e4cb7a8b9..28f6e2e7bcbf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
# Contributor: Alexey D. <lq07829icatm@rambler.ru>
pkgname=psi-plus-git
-pkgver=1.4.1399.r1151.g2170e90
+pkgver=1.4.1555.r1151.g2170e90
pkgrel=1
pkgdesc="Psi+ is a powerful XMPP client (Qt, C++) designed for the XMPP power users (built with Qt 5.x)"
url="https://psi-plus.com"
license=('GPL2')
arch=('x86_64')
-depends=('qt5-base' 'qt5-webengine' 'qt5-multimedia' 'qt5-x11extras' 'qca-qt5'
+depends=('qt5-base' 'qt5-webengine' 'qt5-multimedia' 'qt5-x11extras'
'libidn' 'libxss' 'qt5-svg' 'hunspell' 'qtkeychain' 'http-parser')
makedepends=('git' 'patch' 'cmake')
provides=("psi-plus=$pkgver" "psi-plus-qt5-git=$pkgver")
@@ -47,7 +47,7 @@ prepare() {
}
build() {
- cmake -B build -S psi -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DPSI_PLUS=ON -DCHAT_TYPE=WEBENGINE ..
+ cmake -B build -S psi -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DBUNDLED_USRSCTP=ENABLE -DBUNDLED_QCA=ENABLE -DPSI_PLUS=ON -DCHAT_TYPE=WEBENGINE ..
cmake --build build
}