summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsirlucjan2017-10-17 14:47:35 +0200
committersirlucjan2017-10-17 14:47:35 +0200
commit329da8e1d9d928947e16687baada71248e4c91d1 (patch)
treea26e5171f92e09eb6949e2064f3391471ce985c7
parent188b0236d72c74e1b27aa64f50655e84be4bbaff (diff)
downloadaur-329da8e1d9d928947e16687baada71248e4c91d1.tar.gz
Bump to the newest snapshot && qt5
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD86
-rw-r--r--conf.diff12
-rw-r--r--join.patch26
4 files changed, 94 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd445399725a..43a84a989f2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Wed May 31 13:36:27 UTC 2017
pkgbase = psi-plus-git
- pkgdesc = Psi+ is a powerful Jabber client (Qt, C++) designed for the Jabber power users
- pkgver = 1.0.0.792
+ pkgdesc = Psi+ is a powerful Jabber client (Qt, C++) designed for the Jabber power users (built with Qt 5.x)
+ pkgver = 1.2.81.0.g79c7f8a
pkgrel = 1
url = http://psi-plus.com
arch = i686
@@ -11,25 +9,28 @@ pkgbase = psi-plus-git
makedepends = git
makedepends = patch
makedepends = qconf-git
- depends = qt4
- depends = qca-qt4
+ depends = qt5-base
+ depends = qt5-webkit
+ depends = qt5-multimedia
+ depends = qt5-x11extras
+ depends = qca-qt5
depends = libidn
- depends = enchant
+ depends = aspell
depends = libxss
- optdepends = qca-gnupg: encrypted client-to-client connection
- provides = psi-plus=1.0.0.792
- conflicts = psi-plus
+ depends = qt5-svg
+ provides = psi-plus
+ conflicts = psi-plus-qt5-git
+ conflicts = psi-plus-webkit-qt5-git
conflicts = psi-plus-webkit-git
- replaces = psi-plus
- replaces = psi-plus-webkit-git
- source = git://github.com/psi-im/psi.git
- source = psi-plus::git://github.com/psi-plus/main.git
- source = git://github.com/psi-im/iris.git
- source = git://github.com/psi-im/libpsi.git
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
+ conflicts = psi-plus
+ source = git://github.com/psi-plus/psi-plus-snapshots
+ source = git://github.com/psi-plus/main.git
+ source = conf.diff
+ source = join.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 690770c7c8976d536d8c4078d01c28f187f510574ddffe91251f5045fa672e53
+ sha256sums = 8b2ab645005fab4ca9c7fc84f57e94e1796309e780b535010b84eb0c191ad42c
pkgname = psi-plus-git
diff --git a/PKGBUILD b/PKGBUILD
index 3808d7a157fe..d2c1ae252138 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,77 +1,61 @@
-# Maintainer: Alexey D. <lq07829icatm@rambler.ru>
-# Contributor: Joker-jar <joker-jar@yandex.ru>
+# $Id$
+# Maintainer: Piotr Gorski <lucjan.lucjanov@gmail.com>
+# Contributor: Sergej Pupykin <arch+pub@sergej.pp.ru>
-pkgname="psi-plus-git"
-pkgver=1.0.0.792
+pkgname=psi-plus-git
+pkgver=1.2.81.0.g79c7f8a
pkgrel=1
-pkgdesc="Psi+ is a powerful Jabber client (Qt, C++) designed for the Jabber power users"
+pkgdesc="Psi+ is a powerful Jabber client (Qt, C++) designed for the Jabber power users (built with Qt 5.x)"
url="http://psi-plus.com"
license=('GPL2')
arch=('i686' 'x86_64')
-depends=('qt4' 'qca-qt4' 'libidn' 'enchant' 'libxss')
+depends=('qt5-base' 'qt5-webkit' 'qt5-multimedia' 'qt5-x11extras' 'qca-qt5'
+ 'libidn' 'aspell' 'libxss' 'qt5-svg')
makedepends=('git' 'patch' 'qconf-git')
-optdepends=('qca-gnupg: encrypted client-to-client connection')
-provides=("psi-plus=$pkgver")
-replaces=('psi-plus' 'psi-plus-webkit-git')
-conflicts=('psi-plus' 'psi-plus-webkit-git')
-source=('git://github.com/psi-im/psi.git'
- 'psi-plus::git://github.com/psi-plus/main.git'
- 'git://github.com/psi-im/iris.git'
- 'git://github.com/psi-im/libpsi.git')
-md5sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+provides=('psi-plus')
+conflicts=('psi-plus-qt5-git' 'psi-plus-webkit-qt5-git' 'psi-plus-webkit-git' 'psi-plus')
+source=("git://github.com/psi-plus/psi-plus-snapshots"
+ "git://github.com/psi-plus/main.git"
+ 'conf.diff'
+ 'join.patch')
+sha256sums=('SKIP'
+ 'SKIP'
+ '690770c7c8976d536d8c4078d01c28f187f510574ddffe91251f5045fa672e53'
+ '8b2ab645005fab4ca9c7fc84f57e94e1796309e780b535010b84eb0c191ad42c')
-pkgver() {
- cd "$srcdir"/psi-plus
-
- PSI_PLUS_REVISION="$(git describe --tags --long | cut -d - -f 2)"
- PSI_PLUS_TAG="$(git describe --tags | cut -d - -f 1)"
- PSI_REVISION="$(cd "$srcdir"/psi && git describe --tags --long | cut -d - -f 2)"
-
- echo "${PSI_PLUS_TAG}.${PSI_PLUS_REVISION}.${PSI_REVISION}"
-}
+pkgver() {
+ cd psi-plus-snapshots
+ git describe --long --tags | sed 's/^v//;s/-/./g'
+}
+
prepare() {
- cd psi
-
- # makepkg doesn't support --recursive
- # so setup git modules manually
- git submodule init
- git config submodule.iris.url "$srcdir/iris"
- git config submodule.src/libpsi.url "$srcdir/libpsi"
- git submodule update
-
- # patches from Psi+ project
- for patch in "$srcdir"/psi-plus/patches/*.diff; do
- echo "* Appling ${patch##*/}"
- patch -p1 -i "$patch"
- done
-
- # additional icon themes
- cp -a "$srcdir"/psi-plus/iconsets .
-
+ cd psi-plus-snapshots
# make build date in --version output a bit more readable
#sed "s/yyyyMMdd/yyyy-MM-dd/" -i qcm/conf.qcm
- echo "$(pkgver) ($(date +"%Y-%m-%d"))" >version
+ mkdir -p iconsets
+ cp -r "$srcdir"/main/iconsets/* ./iconsets
+ echo "$pkgver ($(date +"%Y-%m-%d"))" >version
+ patch -p1 <"$srcdir"/join.patch
}
build() {
- cd psi
-
+ cd psi-plus-snapshots
qconf
+ patch -p0 < "$srcdir"/conf.diff
./configure --prefix=/usr \
- --qtdir="/usr/lib/qt4"
+ --libdir=/usr/lib \
+ --disable-enchant \
+ --enable-whiteboarding
make
+ patch -Rp0 < "$srcdir"/conf.diff
}
package() {
- cd psi
+ cd psi-plus-snapshots
make INSTALL_ROOT="$pkgdir" install
install -dm755 "$pkgdir/usr/include/psi-plus/plugins"
install -m644 src/plugins/include/*.h "$pkgdir/usr/include/psi-plus/plugins"
}
-
diff --git a/conf.diff b/conf.diff
new file mode 100644
index 000000000000..2b58af1a3cf2
--- /dev/null
+++ b/conf.diff
@@ -0,0 +1,12 @@
+--- configure.old 2016-04-16 16:10:54.312012000 +0300
++++ configure 2016-04-16 16:11:15.062012000 +0300
+@@ -994,7 +994,8 @@
+ conf->addIncludePath(inc);
+ }
+ conf->addLib(libs);
+-
++ conf->addExtra("CONFIG += psi-minizip");
++ return true;
+ #ifdef Q_OS_WIN
+ // HACK: on windows, always use psi's bundled minizip
+ conf->addExtra("CONFIG += psi-minizip");
diff --git a/join.patch b/join.patch
new file mode 100644
index 000000000000..b315a384575b
--- /dev/null
+++ b/join.patch
@@ -0,0 +1,26 @@
+diff --git a/src/groupchatdlg.cpp b/src/groupchatdlg.cpp
+index 294bee2..6473998 100644
+--- a/src/groupchatdlg.cpp
++++ b/src/groupchatdlg.cpp
+@@ -1508,7 +1508,7 @@ void GCMainDlg::goConn()
+ QString nick = d->self;
+
+ if(!account()->groupChatJoin(host, room, nick, d->password)) {
+- appendSysMsg(tr("Error: You are in or joining this room already!"), true);
++// appendSysMsg(tr("Error: You are in or joining this room already!"), true);
+ d->state = Private::Idle;
+ }
+ }
+diff --git a/src/mucjoindlg.cpp b/src/mucjoindlg.cpp
+index 244c3e8..1a1d4e8 100644
+--- a/src/mucjoindlg.cpp
++++ b/src/mucjoindlg.cpp
+@@ -221,7 +221,7 @@ void MUCJoinDlg::doJoin(MucJoinReason r)
+
+
+ if (!account_->groupChatJoin(host, room, nick, pass, !ui_.ck_history->isChecked())) {
+- QMessageBox::information(this, tr("Error"), tr("You are in or joining this room already!"));
++// QMessageBox::information(this, tr("Error"), tr("You are in or joining this room already!"));
+ return;
+ }
+