summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2018-06-18 00:59:36 +0200
committerPiotr Gorski2018-06-18 00:59:36 +0200
commitd2fa0638b6161da283677b35944a14e8501b54b9 (patch)
tree99ce6b9ba2a2985ca71f72e36e96655b9e18ceaa
parentf4724f1cc02b51d3018855d494fc4d92898e0207 (diff)
downloadaur-d2fa0638b6161da283677b35944a14e8501b54b9.tar.gz
Improve pkgver
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a76cc7d34837..ee5ded26023b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = psi-plus-git
pkgdesc = Psi+ is a powerful XMPP client (Qt, C++) designed for the XMPP power users (built with Qt 5.x)
- pkgver = 1.3.369.g1a3a94b7
+ pkgver = 1.3.384.r1067.ga7d8ec8
pkgrel = 1
url = https://psi-plus.com
arch = x86_64
@@ -18,8 +18,8 @@ pkgbase = psi-plus-git
depends = qt5-svg
depends = hunspell
depends = qtkeychain
- provides = psi-plus=1.3.369.g1a3a94b7
- provides = psi-plus-qt5-git=1.3.369.g1a3a94b7
+ provides = psi-plus=1.3.384.r1067.ga7d8ec8
+ provides = psi-plus-qt5-git=1.3.384.r1067.ga7d8ec8
conflicts = psi-plus
conflicts = psi-plus-qt5-git
conflicts = psi-plus-webkit-qt5-git
diff --git a/PKGBUILD b/PKGBUILD
index acf9bdfdd6ca..d40454cfd1f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Alexey D. <lq07829icatm@rambler.ru>
pkgname=psi-plus-git
-pkgver=1.3.369.g1a3a94b7
+pkgver=1.3.384.r1067.ga7d8ec8
pkgrel=1
pkgdesc="Psi+ is a powerful XMPP client (Qt, C++) designed for the XMPP power users (built with Qt 5.x)"
url="https://psi-plus.com"
@@ -26,8 +26,9 @@ sha256sums=('SKIP'
pkgver() {
- cd psi
- git describe --long --tags | sed 's/^v//;s/-/./g'
+ cd psi-plus
+ _ver="$(cat "${srcdir}/psi/version" | cut -d ' ' -f 1)"
+ echo "${_ver}.r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
prepare() {