summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey D2015-06-14 10:46:59 +0300
committerAlexey D2015-06-14 10:46:59 +0300
commita069e5ed27bc63c9bf3376a9c6e230dd3002c56c (patch)
tree9dc5eed7f39d32d1f229ea8b59be1fc8669276fb
downloadaur-a069e5ed27bc63c9bf3376a9c6e230dd3002c56c.tar.gz
initial version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a62d82ad5398
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = psi-plus-l10n-git
+ pkgdesc = Language packs for Psi+
+ pkgver = 0.16.457
+ pkgrel = 1
+ url = http://psi-plus.com
+ arch = any
+ license = GPL2
+ makedepends = qt4
+ depends = psi-plus-git
+ options = !strip
+ options = !zipman
+ source = git://github.com/psi-plus/psi-plus-l10n.git
+ md5sums = SKIP
+
+pkgname = psi-plus-l10n-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e16d322e5869
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Alexey D. <lq07829icatm@rambler.ru>
+
+pkgname=psi-plus-l10n-git
+pkgver=0.16.457
+pkgrel=1
+pkgdesc="Language packs for Psi+"
+arch=('any')
+url="http://psi-plus.com"
+license=('GPL2')
+makedepends=('qt4')
+depends=('psi-plus-git')
+options=('!strip' '!zipman')
+source=('git://github.com/psi-plus/psi-plus-l10n.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd psi-plus-l10n
+
+ git describe --tags | cut -d - -f 1-2 --output-delimiter=.
+}
+
+build() {
+ cd psi-plus-l10n/translations
+
+ for langfile in *.ts; do
+ lrelease-qt4 "$langfile"
+ done
+}
+
+package() {
+ cd psi-plus-l10n/translations
+
+ install -v -dm755 "$pkgdir/usr/share/psi-plus/translations"
+ install -v -m644 *.qm "$pkgdir/usr/share/psi-plus/translations"
+}