summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgilcu32022-03-24 13:37:13 +0100
committergilcu32022-03-24 13:37:13 +0100
commit0fc529a0da9c9cabfeda9d0aa2d2307cef51b57e (patch)
tree15443efbed3f166ca1acd9e249eb35452080cda2
parente38d04d11e25c8bb2e9ec273e2ab67a81fbc11e0 (diff)
downloadaur-0fc529a0da9c9cabfeda9d0aa2d2307cef51b57e.tar.gz
no need for upx support
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--make.bash10
3 files changed, 5 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80230feefb54..293fa37e6fff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = psiphon-tunnel-core-git
pkgdesc = Psiphon Tunnelling Proxy
pkgver = 2.0.20.r3554.9efdd083
pkgrel = 1
- epoch = 2
+ epoch = 3
url = https://github.com/Psiphon-Labs/psiphon-tunnel-core
arch = x86_64
license = GPL3
@@ -19,6 +19,6 @@ pkgbase = psiphon-tunnel-core-git
sha256sums = SKIP
sha256sums = c2c414831ad29bdeecd00313c473fbaa448f4750e70df1c10e863870bde179aa
sha256sums = d0227e69cac62480951e9c83747d43fccd7bdd18224652428ab20369b84173aa
- sha256sums = SKIP
+ sha256sums = 73ead204b4f0aa4f0a5f5ed174257b10dbb6f7430c5abacc450ea000adfd12da
pkgname = psiphon-tunnel-core-git
diff --git a/PKGBUILD b/PKGBUILD
index 80a607012da5..92566010d9ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ _pkgname=psiphon-tunnel-core
pkgname="$_pkgname-git"
pkgver=2.0.20.r3554.9efdd083
pkgrel=1
-epoch=2
+epoch=3
pkgdesc='Psiphon Tunnelling Proxy'
arch=($CARCH)
url="https://github.com/Psiphon-Labs/psiphon-tunnel-core"
@@ -38,7 +38,7 @@ backup=('etc/psiphon.conf' 'usr/lib/systemd/user/psiphon.service')
sha256sums=('SKIP'
'c2c414831ad29bdeecd00313c473fbaa448f4750e70df1c10e863870bde179aa'
'd0227e69cac62480951e9c83747d43fccd7bdd18224652428ab20369b84173aa'
- 'SKIP')
+ '73ead204b4f0aa4f0a5f5ed174257b10dbb6f7430c5abacc450ea000adfd12da')
pkgver() {
cd $_pkgname
@@ -62,9 +62,6 @@ build() {
./make.bash linux
- # TODO: Figure out how to do the stripping?
- # https://wiki.archlinux.org/index.php/Go_package_guidelines#Flags_and_build_options
-
}
package() {
diff --git a/make.bash b/make.bash
index 1c8094331ea2..b25cc13a8692 100644
--- a/make.bash
+++ b/make.bash
@@ -62,19 +62,11 @@ build_for_linux () {
-o bin/linux/${EXE_BASENAME}-x86_64
RETVAL=$?
if [ $RETVAL != 0 ]; then
- echo "....gox failed, exiting"
+ echo "....go failed, exiting"
exit $RETVAL
fi
unset RETVAL
- #echo "....UPX packaging output"
- #goupx --best bin/linux/${EXE_BASENAME}-x86_64
- #RETVAL=$?
- #if [ $RETVAL != 0 ]; then
- #echo ".....goupx failed, exiting"
- #exit $RETVAL
- #fi
- #unset RETVAL
}
TARGET=$1