summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgilcu32023-12-05 22:47:24 +0100
committergilcu32023-12-05 22:47:24 +0100
commitc23c41d972dc4f9813c7ac92f7ec800d66277bf1 (patch)
tree23ca8f72a0b853b66a38fd4c5c2e7b2396067ebd
parent2ad8a5abb77e585bcf98f9b6a643f284f5465d33 (diff)
downloadaur-c23c41d972dc4f9813c7ac92f7ec800d66277bf1.tar.gz
upd go version; quic patch not needed
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--quic_disabled.go.patch20
3 files changed, 8 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 562c18b4325d..bbe7b977b907 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = psiphon-tunnel-core-git
pkgdesc = Psiphon Tunnelling Proxy
- pkgver = 2.0.29.r3855.b2279f7b
- pkgrel = 2
+ pkgver = 2.0.29.r3904.0cb1c84c
+ pkgrel = 1
epoch = 3
url = https://github.com/Psiphon-Labs/psiphon-tunnel-core
install = psiphon.install
@@ -18,13 +18,11 @@ pkgbase = psiphon-tunnel-core-git
source = client.config
source = psiphon-client.service
source = psiphon-server.service
- source = quic_disabled.go.patch
- source = https://storage.googleapis.com/golang/go1.19.8.linux-amd64.tar.gz
+ source = https://storage.googleapis.com/golang/go1.20.10.linux-amd64.tar.gz
sha256sums = SKIP
sha256sums = c2c414831ad29bdeecd00313c473fbaa448f4750e70df1c10e863870bde179aa
sha256sums = 6711a12112a594ba70bbae51c66ee23302e08c54c4e059c92b67adba9451c037
sha256sums = 373c1eb939118055f799237df3e665680b8dc4b4a281505cce32e957a9554c56
- sha256sums = 4257724404190434e6e45de83fb0ca1270d1f3e2d66ae18028bafb054b03319d
- sha256sums = e1a0bf0ab18c8218805a1003fd702a41e2e807710b770e787e5979d1cf947aba
+ sha256sums = 80d34f1fd74e382d86c2d6102e0e60d4318461a7c2f457ec1efc4042752d4248
pkgname = psiphon-tunnel-core-git
diff --git a/PKGBUILD b/PKGBUILD
index b8aa74f675c1..b6f7c4fc5579 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
_pkgname=psiphon-tunnel-core
pkgname="$_pkgname-git"
-pkgver=2.0.29.r3855.b2279f7b
-pkgrel=2
-GOVERSION=go1.19.8
+pkgver=2.0.29.r3904.0cb1c84c
+pkgrel=1
+GOVERSION=go1.20.10
epoch=3
pkgdesc='Psiphon Tunnelling Proxy'
arch=('i686' 'x86_64')
@@ -18,7 +18,6 @@ source=("git+$url.git"
"client.config"
"psiphon-client.service"
"psiphon-server.service"
- "quic_disabled.go.patch"
"https://storage.googleapis.com/golang/${GOVERSION}.linux-amd64.tar.gz"
)
install=psiphon.install
@@ -27,8 +26,7 @@ sha256sums=('SKIP'
'c2c414831ad29bdeecd00313c473fbaa448f4750e70df1c10e863870bde179aa'
'6711a12112a594ba70bbae51c66ee23302e08c54c4e059c92b67adba9451c037'
'373c1eb939118055f799237df3e665680b8dc4b4a281505cce32e957a9554c56'
- '4257724404190434e6e45de83fb0ca1270d1f3e2d66ae18028bafb054b03319d'
- 'e1a0bf0ab18c8218805a1003fd702a41e2e807710b770e787e5979d1cf947aba')
+ '80d34f1fd74e382d86c2d6102e0e60d4318461a7c2f457ec1efc4042752d4248')
pkgver() {
@@ -41,7 +39,6 @@ pkgver() {
prepare(){
cd "$srcdir/${_pkgname}"
- patch --strip=1 --input=../quic_disabled.go.patch
}
diff --git a/quic_disabled.go.patch b/quic_disabled.go.patch
deleted file mode 100644
index 05c4d5a913da..000000000000
--- a/quic_disabled.go.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/psiphon/common/quic/quic_disabled.go b/psiphon/common/quic/quic_disabled.go
-index df8f0095..d406316c 100644
---- a/psiphon/common/quic/quic_disabled.go
-+++ b/psiphon/common/quic/quic_disabled.go
-@@ -30,6 +30,7 @@ import (
- "github.com/Psiphon-Labs/psiphon-tunnel-core/psiphon/common"
- "github.com/Psiphon-Labs/psiphon-tunnel-core/psiphon/common/errors"
- "github.com/Psiphon-Labs/psiphon-tunnel-core/psiphon/common/prng"
-+ "github.com/Psiphon-Labs/psiphon-tunnel-core/psiphon/common/obfuscator"
- )
-
- // Enabled indicates if QUIC functionality is enabled.
-@@ -60,6 +61,7 @@ func Dial(
- _ *prng.Seed,
- _ string,
- _ *prng.Seed,
-+ _ *transforms.ObfuscatorSeedTransformerParameters,
- _ bool) (net.Conn, error) {
-
- return nil, errors.TraceNew("operation is not enabled")