summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgilcu32021-02-28 19:06:26 +0100
committergilcu32021-02-28 19:06:26 +0100
commitfb7ee02303ce81c2c90f1117818775b2d987611c (patch)
tree5733370c37e570dbc4f5e74932096b40d5798312
parent1044560efe55f965b7a8ab8fbb18f90a37013f61 (diff)
downloadaur-fb7ee02303ce81c2c90f1117818775b2d987611c.tar.gz
hopefully fixed error when updating after package has been built
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90c3747cf98f..bbdfd015ab6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = psiphon-tunnel-core-git
pkgdesc = Psiphon Tunnelling Proxy
pkgver = 2.0.14.r3354.08f530bd
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Psiphon-Labs/psiphon-tunnel-core
arch = x86_64
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index ffae271b7af2..399c902723b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,12 +20,12 @@
_pkgname=psiphon-tunnel-core
pkgname="$_pkgname-git"
pkgver=2.0.14.r3354.08f530bd
-pkgrel=1
+pkgrel=2
pkgdesc='Psiphon Tunnelling Proxy'
arch=('x86_64')
url="https://github.com/Psiphon-Labs/psiphon-tunnel-core"
license=('GPL')
-makedepends=('go-pie' 'perl' 'docker' 'git')
+makedepends=('go-pie' 'perl' 'docker' 'git' 'fakeroot')
depends=('glibc')
source=("git+$url.git"
"psiphon.conf"
@@ -61,12 +61,12 @@ build() {
docker build --no-cache=true -t psiclient .
docker images
cd .. && \
- docker run \
+ fakeroot docker run \
--rm \
-v $PWD:/go/src/github.com/Psiphon-Labs/psiphon-tunnel-core \
psiclient \
- /bin/bash -c './make.bash linux' \
- ; cd -
+ /bin/bash -c './make.bash linux 64' \
+ ; exit; cd -
}
package() {