summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothée Ravier2013-11-03 19:42:41 +0100
committerTimothée Ravier2013-11-03 19:42:41 +0100
commit9d744d46157eb9a6a88e450541486cce4e62ee26 (patch)
treecb77df312fd3c6a605334df1264a4aebf80c3e46
downloadaur-9d744d46157eb9a6a88e450541486cce4e62ee26.tar.gz
General update: SELinux userspace & pkg renaming
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
-rw-r--r--psmisc-22.20-fix-selinux-in-pstree.patch39
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e50ced4aa995
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = psmisc-selinux
+ pkgdesc = Miscellaneous procfs tools with SELinux support
+ pkgver = 22.20
+ pkgrel = 1
+ url = http://psmisc.sourceforge.net/index.html
+ arch = i686
+ arch = x86_64
+ groups = selinux
+ license = GPL
+ depends = ncurses
+ provides = psmisc=22.20-1
+ conflicts = psmisc
+ source = http://downloads.sourceforge.net/psmisc/psmisc-22.20.tar.gz
+ source = psmisc-22.20-fix-selinux-in-pstree.patch
+ sha1sums = abdddc8d5c91251bba0f3190956ae9d05c058745
+ sha1sums = ec7bf64a4700c79672e72c321772df1203cb3f99
+
+pkgname = psmisc-selinux
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b68c30ac948a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id$
+# Maintainer: Eric Bélanger <eric@archlinux.org>
+# SELinux Maintainer: Timothée Ravier <tim@siosm.fr>
+# SELinux Contributor: Nicky726 <Nicky726@gmail.com>
+
+pkgname=psmisc-selinux
+pkgver=22.20
+pkgrel=1
+pkgdesc="Miscellaneous procfs tools with SELinux support"
+arch=('i686' 'x86_64')
+url="http://psmisc.sourceforge.net/index.html"
+license=('GPL')
+groups=('selinux')
+depends=('ncurses')
+conflicts=("${pkgname/-selinux}")
+provides=("${pkgname/-selinux}=${pkgver}-${pkgrel}")
+source=(http://downloads.sourceforge.net/psmisc/${pkgname/-selinux}-${pkgver}.tar.gz
+ psmisc-22.20-fix-selinux-in-pstree.patch)
+sha1sums=('abdddc8d5c91251bba0f3190956ae9d05c058745'
+ 'ec7bf64a4700c79672e72c321772df1203cb3f99')
+
+prepare() {
+ cd ${pkgname/-selinux}-${pkgver}
+ patch -Np1 -i ../psmisc-22.20-fix-selinux-in-pstree.patch
+}
+
+build() {
+ cd "${srcdir}/${pkgname/-selinux}-${pkgver}"
+ ./configure --prefix=/usr --enable-selinux
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname/-selinux}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/psmisc-22.20-fix-selinux-in-pstree.patch b/psmisc-22.20-fix-selinux-in-pstree.patch
new file mode 100644
index 000000000000..d89d6c1f590c
--- /dev/null
+++ b/psmisc-22.20-fix-selinux-in-pstree.patch
@@ -0,0 +1,39 @@
+--- psmisc-22.20/src/pstree.c 2012-09-19 14:05:43.000000000 +0100
++++ psmisc-22.20-selinux/src/pstree.c 2012-10-08 19:18:13.992951873 +0100
+@@ -140,7 +140,12 @@
+ static int dumped = 0; /* used by dump_by_user */
+ static int charlen = 0; /* length of character */
+
++#ifdef WITH_SELINUX
++static void fix_orphans(security_context_t scontext);
++#else
+ static void fix_orphans(void);
++#endif
++
+ /*
+ * Allocates additional buffer space for width and more as needed.
+ * The first call will allocate the first buffer.
+@@ -787,7 +792,11 @@
+ }
+ }
+ (void) closedir(dir);
++#ifdef WITH_SELINUX
++ fix_orphans(scontext);
++#else
+ fix_orphans();
++#endif
+ if (print_args)
+ free(buffer);
+ if (empty) {
+@@ -796,7 +805,11 @@
+ }
+ }
+
++#ifdef WITH_SELINUX
++static void fix_orphans(security_context_t scontext)
++#else
+ static void fix_orphans(void)
++#endif
+ {
+ /* When using kernel 3.3 with hidepid feature enabled on /proc
+ * then we need fake root pid and gather all the orphan processes