summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Zamarin2016-07-17 18:56:43 +0300
committerArthur Zamarin2016-07-17 18:56:43 +0300
commit825b7a17e77cad4925283b2597821d60094c009d (patch)
treed5a880dc7db0ba24dff7905e7f12e3b4879cb999
parentff48bb56237b09a2734102242a7216634f042cf1 (diff)
downloadaur-825b7a17e77cad4925283b2597821d60094c009d.tar.gz
Update
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3cbae94d034..a2df49c127ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Jul 17 15:56:43 UTC 2016
pkgbase = psmoveapi
pkgdesc = Playstation Move Motion Controller API
- pkgver = 3.0.0
+ pkgver = 3.9.1
pkgrel = 1
url = http://thp.io/2010/psmove/
arch = i686
arch = x86_64
license = GPL2
makedepends = cmake
+ makedepends = git
depends = bluez-libs
depends = libsystemd
- source = https://moveonpc.googlecode.com/files/psmoveapi-3.0.0.tar.gz
- sha1sums = 37a60e8fa98cf30358899fbbff37c4a9636b813f
+ source = http://thp.io/2010/psmove/psmoveapi-3.9.1.tar.gz
+ sha1sums = d295e34c4ace3d0b5b0c977ae96b0200160302b7
pkgname = psmoveapi
diff --git a/PKGBUILD b/PKGBUILD
index e6b6f6b927d1..5720528ccbb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,24 @@
# Maintainer: Arthur Zamarin <arthurzam@gmail.com>
pkgname=psmoveapi
-pkgver=3.0.0
+pkgver=3.9.1
pkgrel=1
pkgdesc="Playstation Move Motion Controller API"
arch=(i686 x86_64)
url="http://thp.io/2010/psmove/"
license=('GPL2')
depends=('bluez-libs' 'libsystemd')
-makedepends=('cmake')
-source=("https://moveonpc.googlecode.com/files/$pkgname-$pkgver.tar.gz")
-sha1sums=('37a60e8fa98cf30358899fbbff37c4a9636b813f')
+makedepends=('cmake' 'git')
+source=("http://thp.io/2010/psmove/$pkgname-$pkgver.tar.gz")
+sha1sums=('d295e34c4ace3d0b5b0c977ae96b0200160302b7')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
- cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr .
+ git clone --depth 1 git://github.com/signal11/hidapi.git external/hidapi
+ git clone --depth 1 git://github.com/inspirit/PS3EYEDriver.git external/PS3EYEDriver
+ git clone --depth 1 https://github.com/libusb/libusb.git external/libusb-1.0
+ git clone --depth 1 https://github.com/spurious/SDL-mirror external/SDL2
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr -DPSMOVEAPI_LIB_DEST=lib .
}
build() {