summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Zamarin2016-07-30 11:55:51 +0300
committerArthur Zamarin2016-07-30 11:55:51 +0300
commitab963162410e8416a49463643bc161ef242ec4eb (patch)
treedcf4bc22145c44c14357e5be51b70e589fb238c4
parent03cbe55fe18b69d8c61bfd23548fb0e10e2580d4 (diff)
downloadaur-ab963162410e8416a49463643bc161ef242ec4eb.tar.gz
Update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 385b4f587f48..7024f3c1cf76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Jul 20 15:12:51 UTC 2016
+# Sat Jul 30 08:55:51 UTC 2016
pkgbase = psmoveapi
pkgdesc = Playstation Move Motion Controller API
pkgver = 3.9.1
- pkgrel = 2
+ pkgrel = 3
url = http://thp.io/2010/psmove/
arch = i686
arch = x86_64
@@ -12,6 +12,8 @@ pkgbase = psmoveapi
makedepends = git
depends = bluez-libs
depends = libsystemd
+ depends = opencv
+ depends = sdl2
source = http://thp.io/2010/psmove/psmoveapi-3.9.1.tar.gz
sha1sums = d295e34c4ace3d0b5b0c977ae96b0200160302b7
diff --git a/PKGBUILD b/PKGBUILD
index ea510a7c5871..e92ce4e84cba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,32 @@
pkgname=psmoveapi
pkgver=3.9.1
-pkgrel=2
+pkgrel=3
pkgdesc="Playstation Move Motion Controller API"
arch=(i686 x86_64)
url="http://thp.io/2010/psmove/"
license=('custom')
-depends=('bluez-libs' 'libsystemd')
+depends=('bluez-libs' 'libsystemd' 'opencv' 'sdl2')
makedepends=('cmake' 'git')
source=("http://thp.io/2010/psmove/$pkgname-$pkgver.tar.gz")
sha1sums=('d295e34c4ace3d0b5b0c977ae96b0200160302b7')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
- git clone --depth 1 git://github.com/signal11/hidapi.git external/hidapi
- git clone --depth 1 git://github.com/inspirit/PS3EYEDriver.git external/PS3EYEDriver
- git clone --depth 1 https://github.com/libusb/libusb.git external/libusb-1.0
- git clone --depth 1 https://github.com/spurious/SDL-mirror external/SDL2
- cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr -DPSMOVEAPI_LIB_DEST=lib .
+ git clone --depth 1 git://github.com/signal11/hidapi.git external/hidapi || true
+ git clone --depth 1 git://github.com/inspirit/PS3EYEDriver.git external/PS3EYEDriver || true
+ git clone --depth 1 https://github.com/libusb/libusb.git external/libusb-1.0 || true
+ git clone --depth 1 https://github.com/spurious/SDL-mirror external/SDL2 || true
}
build() {
cd "$srcdir/$pkgname-$pkgver"
+ cmake . \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DPSMOVEAPI_LIB_DEST=lib \
+ -DPSMOVE_BUILD_EXAMPLES=OFF \
+ -DPSMOVE_BUILD_OPENGL_EXAMPLES=OFF \
+ -DPSMOVE_BUILD_TESTS=OFF
make
}