summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-04-29 20:00:29 +0200
committerMichel Zou2020-04-29 20:00:29 +0200
commiteb81608b05d19494e26555a346102339f71f958c (patch)
tree923c37b666fb53329d457e9dbec079650583ab07
parentfbb89ca2cdc1c4f5bd6dbb31ead9dc8686327779 (diff)
downloadaur-eb81608b05d19494e26555a346102339f71f958c.tar.gz
cleanup
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 11 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e37f41e7ed7..b653113baba9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,19 @@
-# Generated by mksrcinfo v8
-# Tue Sep 13 17:09:19 UTC 2016
pkgbase = psp-binutils
pkgdesc = A set of programs to assemble and manipulate binary and object files (psp)
pkgver = 2.22
pkgrel = 1
- url = http://www.gnu.org/software/binutils/
- arch = i686
+ url = https://github.com/pspdev/psptoolchain
arch = x86_64
groups = psp
license = GPL
makedepends = gcc
depends = zlib
+ depends = flex
options = !buildflags
options = !strip
options = staticlibs
- source = http://ftp.gnu.org/pub/gnu/binutils/binutils-2.22.tar.bz2
- source = binutils-2.22-PSP.patch
- source = binutils-2.22-texinfofix.patch
- md5sums = ee0f10756c84979622b992a4a61ea3f5
- md5sums = a30ab9c15c985c771a42b19f3356d42b
- md5sums = 771f36e63bc53732990f02ef42a475c9
+ source = https://ftp.gnu.org/pub/gnu/binutils/binutils-2.22.tar.bz2
+ sha256sums = 6c7af8ed1c8cf9b4b9d6e6fe09a3e1d3d479fe63984ba8b9b26bf356b6313ca9
pkgname = psp-binutils
diff --git a/PKGBUILD b/PKGBUILD
index 98382d526fdf..b867116b318f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,22 @@ pkgname=psp-binutils
pkgver=2.22
pkgrel=1
pkgdesc="A set of programs to assemble and manipulate binary and object files (psp)"
-arch=(i686 x86_64)
-url="http://www.gnu.org/software/binutils/"
+arch=(x86_64)
+url="https://github.com/pspdev/psptoolchain"
license=('GPL')
groups=('psp')
-depends=('zlib')
+depends=('zlib' 'flex')
makedepends=('gcc')
options=('!buildflags' '!strip' 'staticlibs')
-source=("http://ftp.gnu.org/pub/gnu/binutils/binutils-$pkgver.tar.bz2"
- 'binutils-2.22-PSP.patch'
- 'binutils-2.22-texinfofix.patch')
-md5sums=('ee0f10756c84979622b992a4a61ea3f5'
- 'a30ab9c15c985c771a42b19f3356d42b'
- '771f36e63bc53732990f02ef42a475c9')
+source=("https://ftp.gnu.org/pub/gnu/binutils/binutils-$pkgver.tar.bz2")
+sha256sums=('6c7af8ed1c8cf9b4b9d6e6fe09a3e1d3d479fe63984ba8b9b26bf356b6313ca9')
prepare ()
{
cd "$srcdir/binutils-$pkgver"
rm -f include/opcode/vfpu.h ld/emulparams/elf_mipsallegrexel_psp.sh ld/scripttempl/elf_psp.sc
- patch -p1 -i "$srcdir"/binutils-2.22-PSP.patch
- patch -p1 -i "$srcdir"/binutils-2.22-texinfofix.patch
+ curl -L https://raw.githubusercontent.com/pspdev/psptoolchain/master/patches/binutils-${pkgver}-PSP.patch | patch -p1
+ curl -L https://raw.githubusercontent.com/pspdev/psptoolchain/master/patches/binutils-${pkgver}-texinfofix.patch | patch -p1
}
build()