summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2018-01-27 16:25:10 +0100
committerMichel Zou2018-01-27 16:25:10 +0100
commit37c625539e3772d88d0458ee70b7f7225f48d110 (patch)
tree38697477ee2c7a7f59b2144c3caed11058b6fae9
parent9bfb32a9ffae13b0abd7d7a722544a8fda82e24e (diff)
downloadaur-37c625539e3772d88d0458ee70b7f7225f48d110.tar.gz
cleanup
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99b703da4fb7..95a86780f2eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Jan 27 11:17:56 UTC 2018
+# Sat Jan 27 15:25:09 UTC 2018
pkgbase = psp-gcc
pkgdesc = The GNU Compiler Collection - C and C++ frontends (psp)
pkgver = 4.9.3
diff --git a/PKGBUILD b/PKGBUILD
index 93af340b6547..2f63dae21d8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,13 +37,12 @@ prepare ()
build()
{
cd "$srcdir/gcc-$pkgver"
-
- # fix conflict with system mpfr 4.0
- export CFLAGS="-I$PWD/mpfr/src/"
-
mkdir -p build-psp && pushd build-psp
../configure --prefix=/usr --target=psp \
- --enable-languages="c,c++" --enable-lto --with-newlib --with-gmp --with-mpfr --enable-cxx-flags="-G0"
+ --enable-languages="c,c++" --enable-lto --with-newlib \
+ --with-gmp-include="${PWD}/../gmp" --with-gmp-lib="${PWD}/gmp/.libs" \
+ --with-mpfr-include="${PWD}/../mpfr/src" --with-mpfr-lib="${PWD}/mpfr/src/.libs" \
+ --enable-cxx-flags="-G0"
make
}