summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2024-01-24 21:04:08 +0100
committerMichel Zou2024-01-24 21:04:08 +0100
commit5e9ccef99f2ae950d0d30dc6b0f2ce5cc1609474 (patch)
treea6656f9aa3032226d6790f3f745bcbac75789715
parenta1f518bf5077c5f99e93e6ca8d88394d65c8fb9d (diff)
downloadaur-5e9ccef99f2ae950d0d30dc6b0f2ce5cc1609474.tar.gz
13.2.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa3e3c7b4522..9966ace97ad4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = psp-gcc
- pkgdesc = The GNU Compiler Collection - C and C++ frontends (psp)
- pkgver = 11.2.0
+ pkgdesc = A port of gcc to the PSP (psp)
+ pkgver = 13.2.0
pkgrel = 1
- url = http://gcc.gnu.org
+ url = https://github.com/pspdev/gcc
arch = x86_64
license = GPL
license = LGPL
@@ -18,7 +18,7 @@ pkgbase = psp-gcc
options = !buildflags
options = !strip
options = staticlibs
- source = gcc-11.2.0::git+https://github.com/pspdev/gcc.git#branch=allegrex-v11.2.0
+ source = gcc-13.2.0::git+https://github.com/pspdev/gcc.git#branch=allegrex-v13.2.0
sha256sums = SKIP
pkgname = psp-gcc
diff --git a/PKGBUILD b/PKGBUILD
index b33ba5801de0..79f2baec8630 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
pkgname=psp-gcc
-pkgver=11.2.0
+pkgver=13.2.0
pkgrel=1
-pkgdesc="The GNU Compiler Collection - C and C++ frontends (psp)"
+pkgdesc="A port of gcc to the PSP (psp)"
arch=('x86_64')
-url="http://gcc.gnu.org"
+url="https://github.com/pspdev/gcc"
license=('GPL' 'LGPL' 'FDL' 'custom')
depends=('psp-binutils' 'psp-newlib' 'psp-pthread-embedded' 'mpfr')
makedepends=('git')
@@ -17,8 +17,8 @@ build()
{
cd "$srcdir/gcc-$pkgver"
mkdir -p build-psp && pushd build-psp
- ../configure --prefix=/usr --target=psp --enable-languages="c,c++" --with-float=hard \
- --with-newlib --disable-libssp --disable-multilib --enable-cxx-flags="-G0" --enable-threads=posix
+ ../configure --quiet --prefix=/usr --target=psp --enable-languages="c,c++" --with-float=hard \
+ --with-newlib --disable-libssp --disable-multilib --enable-cxx-flags="-G0" --enable-threads=posix
make
}
@@ -31,4 +31,3 @@ package()
rm -r "$pkgdir"/usr/share
rm "$pkgdir"/usr/lib/libcc1.*
}
-