summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2018-01-27 12:17:56 +0100
committerMichel Zou2018-01-27 12:17:56 +0100
commit9bfb32a9ffae13b0abd7d7a722544a8fda82e24e (patch)
treea8e23db1cdfba211470dac7dfd6c985523d66111
parent31b7e7feedd0e98c04830f3bd9f7da8e8114923c (diff)
downloadaur-9bfb32a9ffae13b0abd7d7a722544a8fda82e24e.tar.gz
mpfr fix
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ceb5299042bf..99b703da4fb7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Jan 16 20:13:40 UTC 2018
+# Sat Jan 27 11:17:56 UTC 2018
pkgbase = psp-gcc
pkgdesc = The GNU Compiler Collection - C and C++ frontends (psp)
pkgver = 4.9.3
diff --git a/PKGBUILD b/PKGBUILD
index c0ec9eff8775..93af340b6547 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,6 +37,10 @@ prepare ()
build()
{
cd "$srcdir/gcc-$pkgver"
+
+ # fix conflict with system mpfr 4.0
+ export CFLAGS="-I$PWD/mpfr/src/"
+
mkdir -p build-psp && pushd build-psp
../configure --prefix=/usr --target=psp \
--enable-languages="c,c++" --enable-lto --with-newlib --with-gmp --with-mpfr --enable-cxx-flags="-G0"