summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-04-29 20:06:28 +0200
committerMichel Zou2020-04-29 20:06:28 +0200
commitd31840b484da6bc89d2138714db62725f6244c16 (patch)
tree316979fdd93eb2965d3925dd1c3d1f7e5a6b2fba
parent180c2012820be7a1123846fcb90c984e4451e402 (diff)
downloadaur-d31840b484da6bc89d2138714db62725f6244c16.tar.gz
repo
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 11 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca84f2981563..e5cf2442a9c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,8 @@
-# Generated by mksrcinfo v8
-# Sat Mar 10 09:42:24 UTC 2018
pkgbase = psp-newlib
pkgdesc = Newlib is a C library intended for use on embedded systems (psp)
pkgver = 1.20.0
- pkgrel = 2
- url = http://sourceware.org/newlib/
+ pkgrel = 1
+ url = https://github.com/pspdev/newlib
arch = any
groups = psp
license = GPL
@@ -14,10 +12,8 @@ pkgbase = psp-newlib
options = !buildflags
options = !strip
options = staticlibs
- source = ftp://sourceware.org/pub/newlib/newlib-1.20.0.tar.gz
- source = https://raw.githubusercontent.com/pspdev/psptoolchain/master/patches/newlib-1.20.0-PSP.patch
- sha256sums = c644b2847244278c57bec2ddda69d8fab5a7c767f3b9af69aa7aa3da823ff692
- sha256sums = 43630dd12c0148d035a00daa0665b67122cf40bdf2fc587a9db40cb7deeb7dbf
+ source = https://github.com/pspdev/newlib/archive/newlib-1_20_0-PSP.zip
+ sha256sums = SKIP
pkgname = psp-newlib
diff --git a/PKGBUILD b/PKGBUILD
index 314cde867f45..805b54756fea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,27 @@
pkgname=psp-newlib
pkgver=1.20.0
-pkgrel=2
+pkgrel=1
pkgdesc="Newlib is a C library intended for use on embedded systems (psp)"
arch=(any)
-url="http://sourceware.org/newlib/"
+url="https://github.com/pspdev/newlib"
license=('GPL')
groups=('psp')
makedepends=('psp-gcc-base' 'psp-binutils' 'psp-sdk-base')
options=('!buildflags' '!strip' 'staticlibs')
-source=("ftp://sourceware.org/pub/newlib/newlib-$pkgver.tar.gz"
- "https://raw.githubusercontent.com/pspdev/psptoolchain/master/patches/newlib-$pkgver-PSP.patch")
-sha256sums=('c644b2847244278c57bec2ddda69d8fab5a7c767f3b9af69aa7aa3da823ff692'
- '43630dd12c0148d035a00daa0665b67122cf40bdf2fc587a9db40cb7deeb7dbf')
-
-prepare ()
-{
- cd "$srcdir/newlib-$pkgver"
- rm -f newlib/libc/include/memory.h
- rm -rf newlib/libc/sys/psp/
- patch -p1 -i "$srcdir"/newlib-$pkgver-PSP.patch
-}
+source=("https://github.com/pspdev/newlib/archive/newlib-${pkgver//./_}-PSP.zip")
+sha256sums=('SKIP')
build()
{
- cd "$srcdir/newlib-$pkgver"
- mkdir -p build-psp && pushd build-psp
+ cd "$srcdir/newlib-newlib-${pkgver//./_}-PSP"
+ mkdir -p build-psp && cd build-psp
../configure --prefix=/usr --target=psp --enable-newlib-iconv --enable-newlib-multithread --enable-newlib-mb
make
}
package()
{
- cd "$srcdir/newlib-$pkgver/build-psp"
+ cd "$srcdir/newlib-newlib-${pkgver//./_}-PSP/build-psp"
make install DESTDIR="$pkgdir"
rm -r "$pkgdir"/usr/share
rm "$pkgdir"/usr/psp/lib/crt0.o # provided by psp-sdk