summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-06-08 23:33:29 +0200
committerxantares2015-06-08 23:33:29 +0200
commitfd14fb76f8fe74c1b3f2d321eef20c78a1fd594d (patch)
tree4f3fa7508cd0de8505d88071b04761b4c24ae869
downloadaur-psp-zziplib.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d982c1ebe3d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = psp-zziplib
+ pkgdesc = A lightweight library that offers the ability to easily extract data from files archived in a single zip file (psp)
+ pkgver = 0.13.38
+ pkgrel = 1
+ url = http://zziplib.sourceforge.net
+ arch = any
+ groups = psp
+ license = LGPL,
+ license = MPL
+ makedepends = psp-gcc
+ depends = psp-sdk
+ depends = psp-zlib
+ options = !buildflags
+ options = !strip
+ options = staticlibs
+ source = git+https://github.com/pspdev/psp-ports.git
+ md5sums = SKIP
+
+pkgname = psp-zziplib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..390e3887ef54
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: xantares <xantares09 at hotmail dot com>
+
+pkgname=psp-zziplib
+pkgver=0.13.38
+pkgrel=1
+pkgdesc="A lightweight library that offers the ability to easily extract data from files archived in a single zip file (psp)"
+arch=(any)
+url="http://zziplib.sourceforge.net"
+license=('LGPL', 'MPL')
+groups=('psp')
+depends=('psp-sdk' 'psp-zlib')
+makedepends=('psp-gcc')
+options=('!buildflags' '!strip' 'staticlibs')
+source=("git+https://github.com/pspdev/psp-ports.git")
+md5sums=('SKIP')
+
+
+build()
+{
+ cd "$srcdir/psp-ports/zziplib"
+ export LDFLAGS="-L$(psp-config --pspsdk-path)/lib -L$(psp-config --psp-prefix)/lib -lc -lpspuser"
+ export LIBS="-lc -lpspuser"
+ mkdir -p build-psp && pushd build-psp
+ ../configure --prefix=/usr/psp --host=psp
+ make
+}
+
+package()
+{
+ cd "$srcdir/psp-ports/zziplib/build-psp"
+ make install DESTDIR="$pkgdir"
+}
+