summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel Revilla2017-08-14 21:21:25 +0200
committerMiguel Revilla2017-08-14 21:21:25 +0200
commit9e1261c9b4bab1225167946e052ae6e1588014d9 (patch)
treecb91759abfff541225f8fdf1f9d444e94e796dba
parentcf06b60a026ea99406ce51ea60dd95e0d5c00926 (diff)
downloadaur-9e1261c9b4bab1225167946e052ae6e1588014d9.tar.gz
Update to 0.11.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--perl-module.patch11
-rw-r--r--xalloc-oversized.patch11
4 files changed, 8 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c5246ecddd8..ff319bd2ba76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pspp
pkgdesc = Statistical analysis program. Free replacement for SPSS.
- pkgver = 0.10.2
- pkgrel = 2
+ pkgver = 0.11.0
+ pkgrel = 1
url = http://www.gnu.org/software/pspp/
install = pspp.install
arch = i686
@@ -15,12 +15,8 @@ pkgbase = pspp
optdepends = libxml2: GNUMERIC support
options = !libtool
options = !emptydirs
- source = ftp://ftp.gnu.org/gnu/pspp/pspp-0.10.2.tar.gz
- source = perl-module.patch
- source = xalloc-oversized.patch
- md5sums = 9c5a3295d59b07a9a4462148371723ae
- md5sums = bed924eac7dabd2afa65157fbc2d89dd
- md5sums = e62a701045851b052e5e266a25d0cda6
+ source = ftp://ftp.gnu.org/gnu/pspp/pspp-0.11.0.tar.gz
+ md5sums = 4856badd6b3965c51eb126bf46d3e602
pkgname = pspp
diff --git a/PKGBUILD b/PKGBUILD
index e52437ee0a1c..109909a10ca0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Miguel Revilla <yo@miguelrevilla.com>
# Contributor: joyfulgirl <joyfulgirl (at) archlinux.us>
pkgname=pspp
-pkgver=0.10.2
-pkgrel=2
+pkgver=0.11.0
+pkgrel=1
pkgdesc="Statistical analysis program. Free replacement for SPSS."
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/pspp/"
@@ -11,18 +11,12 @@ depends=('gsl' 'gtksourceview3' 'postgresql-libs' 'desktop-file-utils')
optdepends=('zlib: GNUmeric support'
'libxml2: GNUMERIC support')
options=('!libtool' '!emptydirs')
-source=(ftp://ftp.gnu.org/gnu/pspp/pspp-${pkgver}.tar.gz
- 'perl-module.patch'
- 'xalloc-oversized.patch')
-md5sums=('9c5a3295d59b07a9a4462148371723ae'
- 'bed924eac7dabd2afa65157fbc2d89dd'
- 'e62a701045851b052e5e266a25d0cda6')
+source=(ftp://ftp.gnu.org/gnu/pspp/pspp-${pkgver}.tar.gz)
+md5sums=('4856badd6b3965c51eb126bf46d3e602')
install=pspp.install
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p0 < "${srcdir}/perl-module.patch"
- patch -p0 < "${srcdir}/xalloc-oversized.patch"
./configure --prefix=/usr \
--sysconfdir=/etc \
diff --git a/perl-module.patch b/perl-module.patch
deleted file mode 100644
index da66edb728aa..000000000000
--- a/perl-module.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- perl-module/Makefile.PL.orig 2017-07-07 15:02:34.054187220 +0200
-+++ perl-module/Makefile.PL 2017-07-07 15:02:54.420853430 +0200
-@@ -4,7 +4,7 @@
- # the contents of the Makefile that is written.
-
-
--do 'pspp-module-config' || do {
-+do './pspp-module-config' || do {
- my $build = prompt ("Enter the location of the build directory of the configured pspp source:", "" );
- my $src = $top_srcdir;
-
diff --git a/xalloc-oversized.patch b/xalloc-oversized.patch
deleted file mode 100644
index 3c6bc5d0761f..000000000000
--- a/xalloc-oversized.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- gl/xalloc-oversized.h.orig 2017-07-07 15:14:42.847504140 +0200
-+++ gl/xalloc-oversized.h 2017-07-07 15:15:53.110835890 +0200
-@@ -46,7 +46,7 @@
- /* GCC 7 __builtin_mul_overflow should easily compute this. See:
- https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68120 */
- #if 7 <= __GNUC__
--# define xalloc_oversized(n, s) __builtin_mul_overflow (n, s, (size_t *) NULL)
-+# define xalloc_oversized(n, s) __builtin_mul_overflow_p (n, s, (size_t) 1)
-
- /* GCC 5 and Clang __builtin_mul_overflow needs a temporary, and
- should be used only for non-constant operands, so that