summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2019-01-30 13:23:27 -0500
committergraysky2019-01-30 13:23:27 -0500
commit45ea82c50258962f260ae16c48f92302919f9dd2 (patch)
tree8b9c36a20a9143e2096f7534137516e872585687
downloadaur-45ea82c50258962f260ae16c48f92302919f9dd2.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edbe6f5f7d6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = psrecord
+ pkgdesc = Record the CPU and memory activity of a process
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/astrofrog/psrecord
+ arch = x86_64
+ license = BSD
+ makedepends = python
+ makedepends = python-pytest
+ depends = python-psutil
+ depends = python
+ optdepends = python-matplotlib: to generate plots
+ source = psrecord-1.1.tar.gz::https://github.com/astrofrog/psrecord/archive/v1.1.tar.gz
+ sha256sums = 334ff9d1ef4d8ab7c770b840ccb90b9b0e5c0fd4f8d2679e9cf579cdb8846f6b
+
+pkgname = psrecord
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75b15a59e05d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: graysky <graysky AT archlinux DOT us>
+pkgname=psrecord
+pkgver=1.1
+pkgrel=1
+pkgdesc="Record the CPU and memory activity of a process"
+arch=('x86_64')
+url="https://github.com/astrofrog/psrecord"
+license=('BSD')
+depends=('python-psutil' 'python')
+makedepends=('python' 'python-pytest')
+optdepends=('python-matplotlib: to generate plots')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/astrofrog/psrecord/archive/v1.1.tar.gz")
+sha256sums=('334ff9d1ef4d8ab7c770b840ccb90b9b0e5c0fd4f8d2679e9cf579cdb8846f6b')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ pytest psrecord
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root=${pkgdir} --optimize=1
+}