summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgarionion2021-03-25 13:41:45 +0100
committergarionion2021-03-25 13:41:45 +0100
commit5ccfe079bc3657a5b5e4ae624cb515c8acb3f249 (patch)
treef3b8d3a35835cea0ea63a1b6c651f10240c17a49
parent6b45d9b7c348931706b046d7e435eeedd7051043 (diff)
downloadaur-5ccfe079bc3657a5b5e4ae624cb515c8acb3f249.tar.gz
update makedepends
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a68d62d5c6e..be07c5d97324 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = psst-git
pkgdesc = Fast and multi-platform Spotify client with native GUI
- pkgver = 0
+ pkgver = r173.0bb5258
pkgrel = 1
url = https://github.com/jpochyla/psst
arch = x86_64
license = MIT
makedepends = rust
makedepends = git
+ makedepends = gtk3
+ makedepends = cairo
+ makedepends = openssl
provides = psst
conflicts = psst
source = git+https://github.com/jpochyla/psst.git
diff --git a/PKGBUILD b/PKGBUILD
index 68afcf6549df..c3d6a57db2f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,17 @@
pkgname=psst-git
_pkgname="psst"
-pkgver=0
+pkgver=r173.0bb5258
pkgrel=1
pkgdesc="Fast and multi-platform Spotify client with native GUI"
arch=("x86_64")
url="https://github.com/jpochyla/psst"
license=('MIT')
makedepends=( 'rust'
- 'git')
+ 'git'
+ 'gtk3'
+ 'cairo'
+ 'openssl')
provides=("psst")
conflicts=("psst")
source=("git+https://github.com/jpochyla/psst.git")
@@ -17,7 +20,10 @@ sha256sums=('SKIP')
pkgver() {
cd "$_pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
prepare() {