summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgarionion2021-06-25 22:56:22 +0200
committergarionion2021-06-25 22:56:22 +0200
commitd66a9dcdf6a89ea6a1a4453b4d3aaead09133d57 (patch)
treebc3b179df9a9e2a25c4b85d30fa44289cec1c344
parent5ccfe079bc3657a5b5e4ae624cb515c8acb3f249 (diff)
downloadaur-d66a9dcdf6a89ea6a1a4453b4d3aaead09133d57.tar.gz
add clang as makedep
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be07c5d97324..e3016c7d0faa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = psst-git
pkgdesc = Fast and multi-platform Spotify client with native GUI
- pkgver = r173.0bb5258
+ pkgver = r213.4ee0b48
pkgrel = 1
url = https://github.com/jpochyla/psst
arch = x86_64
@@ -10,10 +10,10 @@ pkgbase = psst-git
makedepends = gtk3
makedepends = cairo
makedepends = openssl
+ makedepends = clang
provides = psst
conflicts = psst
source = git+https://github.com/jpochyla/psst.git
sha256sums = SKIP
pkgname = psst-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c3d6a57db2f5..bc059c18f3a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=psst-git
_pkgname="psst"
-pkgver=r173.0bb5258
+pkgver=r213.4ee0b48
pkgrel=1
pkgdesc="Fast and multi-platform Spotify client with native GUI"
arch=("x86_64")
@@ -12,7 +12,8 @@ makedepends=( 'rust'
'git'
'gtk3'
'cairo'
- 'openssl')
+ 'openssl'
+ 'clang')
provides=("psst")
conflicts=("psst")
source=("git+https://github.com/jpochyla/psst.git")
@@ -33,12 +34,12 @@ prepare() {
build() {
cd "$_pkgname"
- cargo build --release --locked --all-features --target-dir=target
+ cargo build --release
}
check() {
cd "$_pkgname"
- cargo test --release --locked --target-dir=target
+ cargo test --release
}
package() {