summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-04-08 11:50:24 -0300
committerDaniel Bermond2017-04-08 11:50:24 -0300
commitace46dc4cdafff9e3a154e76d793f487bfc62b65 (patch)
tree624c2bf0b60946a3f0133c44a3e173c1f3c172ef
parentd553a1b1b9b19ebdb50819f45c8b9a81da4bae82 (diff)
downloadaur-ace46dc4cdafff9e3a154e76d793f487bfc62b65.tar.gz
Brought back libemf support
libemf support was temporarily removed in pstoedit-nomagick 3.70-2 due to a bug in libemf 1.0.8. This bug is now fixed in libemf 1.0.9 and now that the libemf AUR package is updated we can reintroduce it again. Reference: https://aur.archlinux.org/cgit/aur.git/commit/?h=pstoedit-nomagick&id=905895998542bd763a4287852bb524a8c09ff2f0
-rw-r--r--.SRCINFO5
-rwxr-xr-xPKGBUILD8
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 976e8646a06a..c17e8e99ed8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Apr 8 14:31:40 UTC 2017
+# Sat Apr 8 14:48:12 UTC 2017
pkgbase = pstoedit-nomagick
pkgdesc = Translates PS/PDF graphics to other vector formats (no ImageMagick dependency)
pkgver = 3.70
- pkgrel = 4
+ pkgrel = 5
url = http://www.pstoedit.net/
arch = i686
arch = x86_64
@@ -13,6 +13,7 @@ pkgbase = pstoedit-nomagick
depends = libzip
depends = plotutils
depends = ghostscript
+ depends = libemf
provides = pstoedit
provides = libpstoedit.so
conflicts = pstoedit
diff --git a/PKGBUILD b/PKGBUILD
index 8e1a28987c90..6889b8d626bc 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@
_srcname="pstoedit"
pkgname=pstoedit-nomagick
pkgver=3.70
-pkgrel=4
+pkgrel=5
pkgdesc="Translates PS/PDF graphics to other vector formats (no ImageMagick dependency)"
arch=('i686' 'x86_64')
url="http://www.pstoedit.net/"
license=('GPL2')
-depends=('gd' 'ming' 'libzip' 'plotutils' 'ghostscript')
+depends=('gd' 'ming' 'libzip' 'plotutils' 'ghostscript' 'libemf')
provides=('pstoedit' 'libpstoedit.so')
conflicts=('pstoedit')
source=("https://sourceforge.net/projects/pstoedit/files/pstoedit/${pkgver}/${_srcname}-${pkgver}.tar.gz"
@@ -36,7 +36,7 @@ build() {
--prefix=/usr \
--enable-static=no \
--enable-shared=yes \
- --without-emf \
+ --with-emf \
--without-magick \
--with-libplot \
--with-swf \
@@ -46,5 +46,5 @@ build() {
package() {
cd "${_srcname}-${pkgver}"
- make DESTDIR="$pkgdir/" install
+ make DESTDIR="$pkgdir" install
}