summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-04-28 12:19:25 +0000
committerDaniel Bermond2018-04-28 12:37:35 +0000
commitb89ea666b1a60cac2b8c2e63ae3759ac4ade29f1 (patch)
tree442c6dade63ca0d2406aaad142205cf22042258d
parentace46dc4cdafff9e3a154e76d793f487bfc62b65 (diff)
downloadaur-b89ea666b1a60cac2b8c2e63ae3759ac4ade29f1.tar.gz
Cosmetic changes
Also on this commit ------------------- - add gcc-libs to depends - fix license: changed from GPL2 to GPL, since the source files contains the 'any later' statement
-rw-r--r--.SRCINFO7
-rw-r--r--[-rwxr-xr-x]PKGBUILD35
2 files changed, 22 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c17e8e99ed8a..36bbefac6e75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
-# Generated by mksrcinfo v8
-# Sat Apr 8 14:48:12 UTC 2017
pkgbase = pstoedit-nomagick
pkgdesc = Translates PS/PDF graphics to other vector formats (no ImageMagick dependency)
pkgver = 3.70
- pkgrel = 5
+ pkgrel = 6
url = http://www.pstoedit.net/
arch = i686
arch = x86_64
- license = GPL2
+ license = GPL
+ depends = gcc-libs
depends = gd
depends = ming
depends = libzip
diff --git a/PKGBUILD b/PKGBUILD
index 6889b8d626bc..0efeb31469be 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,21 @@
# pstoedit compiled without ImageMagick dependency
-_srcname="pstoedit"
+_srcname=pstoedit
pkgname=pstoedit-nomagick
pkgver=3.70
-pkgrel=5
-pkgdesc="Translates PS/PDF graphics to other vector formats (no ImageMagick dependency)"
+pkgrel=6
+pkgdesc='Translates PS/PDF graphics to other vector formats (no ImageMagick dependency)'
arch=('i686' 'x86_64')
-url="http://www.pstoedit.net/"
-license=('GPL2')
-depends=('gd' 'ming' 'libzip' 'plotutils' 'ghostscript' 'libemf')
+url='http://www.pstoedit.net/'
+license=('GPL')
+depends=('gcc-libs' 'gd' 'ming' 'libzip' 'plotutils' 'ghostscript' 'libemf')
provides=('pstoedit' 'libpstoedit.so')
conflicts=('pstoedit')
source=("https://sourceforge.net/projects/pstoedit/files/pstoedit/${pkgver}/${_srcname}-${pkgver}.tar.gz"
- "02-errors-to-stderr.patch"
- "04-fix-obsolete-LIBPNG_LDFLAGS.patch"
- "05-fix-plugin-loading.patch"
-)
+ '02-errors-to-stderr.patch'
+ '04-fix-obsolete-LIBPNG_LDFLAGS.patch'
+ '05-fix-plugin-loading.patch')
sha256sums=('06b86113f7847cbcfd4e0623921a8763143bbcaef9f9098e6def650d1ff8138c'
'66cd2bd3f92aa4ba57c916f721acd8c42c07fffea5fbc81f075853dab845d6d8'
'3320bbcf6ba33d70213897f41c31c158d4bb4284e17b061ed8d1c38c1ee5a8b8'
@@ -25,26 +24,30 @@ sha256sums=('06b86113f7847cbcfd4e0623921a8763143bbcaef9f9098e6def650d1ff8138c'
prepare() {
cd "${_srcname}-${pkgver}"
- patch -Np1 -i ../02-errors-to-stderr.patch
- patch -Np1 -i ../04-fix-obsolete-LIBPNG_LDFLAGS.patch
- patch -Np1 -i ../05-fix-plugin-loading.patch
+
+ patch -Np1 -i "${srcdir}/02-errors-to-stderr.patch"
+ patch -Np1 -i "${srcdir}/04-fix-obsolete-LIBPNG_LDFLAGS.patch"
+ patch -Np1 -i "${srcdir}/05-fix-plugin-loading.patch"
}
build() {
cd "${_srcname}-${pkgver}"
+
./configure \
- --prefix=/usr \
- --enable-static=no \
- --enable-shared=yes \
+ --prefix='/usr'\
+ --enable-static='no' \
+ --enable-shared='yes' \
--with-emf \
--without-magick \
--with-libplot \
--with-swf \
--with-pptx
+
make
}
package() {
cd "${_srcname}-${pkgver}"
+
make DESTDIR="$pkgdir" install
}