summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-04-28 15:33:41 +0000
committerDaniel Bermond2018-04-28 15:33:41 +0000
commitfbc5903dc2aff1d1d6b3cf1b04bbb0686c32f183 (patch)
tree7d65fd571d4e58b44d01c1a60f360b2c4ea75811
parentb89ea666b1a60cac2b8c2e63ae3759ac4ade29f1 (diff)
downloadaur-fbc5903dc2aff1d1d6b3cf1b04bbb0686c32f183.tar.gz
Updated to version 3.71
-rw-r--r--.SRCINFO14
-rw-r--r--02-errors-to-stderr.patch20
-rw-r--r--04-fix-obsolete-LIBPNG_LDFLAGS.patch2
-rw-r--r--05-fix-plugin-loading.patch34
-rw-r--r--PKGBUILD15
5 files changed, 23 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36bbefac6e75..2063d45f46fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pstoedit-nomagick
pkgdesc = Translates PS/PDF graphics to other vector formats (no ImageMagick dependency)
- pkgver = 3.70
- pkgrel = 6
+ pkgver = 3.71
+ pkgrel = 1
url = http://www.pstoedit.net/
arch = i686
arch = x86_64
@@ -16,14 +16,12 @@ pkgbase = pstoedit-nomagick
provides = pstoedit
provides = libpstoedit.so
conflicts = pstoedit
- source = https://sourceforge.net/projects/pstoedit/files/pstoedit/3.70/pstoedit-3.70.tar.gz
+ source = https://sourceforge.net/projects/pstoedit/files/pstoedit/3.71/pstoedit-3.71.tar.gz
source = 02-errors-to-stderr.patch
source = 04-fix-obsolete-LIBPNG_LDFLAGS.patch
- source = 05-fix-plugin-loading.patch
- sha256sums = 06b86113f7847cbcfd4e0623921a8763143bbcaef9f9098e6def650d1ff8138c
- sha256sums = 66cd2bd3f92aa4ba57c916f721acd8c42c07fffea5fbc81f075853dab845d6d8
- sha256sums = 3320bbcf6ba33d70213897f41c31c158d4bb4284e17b061ed8d1c38c1ee5a8b8
- sha256sums = edec8010f6f05126047ce8f9facf1c36a2c0480a0bac14469b8ffb31a7722625
+ sha256sums = 0589cd22cd9c23dee12d9bc9f26760f872185d8a1fb72a05bc58f6b824cfbc95
+ sha256sums = 3ab9c962cb70744f984083755eafcf6e62b3b603ad060b5a078bcc3bda389448
+ sha256sums = c5a3fd24ff4d57ac7106ee4f9f19e0fb1cd94cbaf7ad53a8ff979bcfe7173139
pkgname = pstoedit-nomagick
diff --git a/02-errors-to-stderr.patch b/02-errors-to-stderr.patch
index 5de42009fef0..a1e447259d51 100644
--- a/02-errors-to-stderr.patch
+++ b/02-errors-to-stderr.patch
@@ -12,10 +12,10 @@ Bug-Debian: http://bugs.debian.org/551125
1 file changed, 13 insertions(+), 13 deletions(-)
diff --git a/src/pstoedit.cpp b/src/pstoedit.cpp
-index 7f66d23..33a297a 100644
+index d3b8fd5..d36f52b 100644
--- a/src/pstoedit.cpp
+++ b/src/pstoedit.cpp
-@@ -414,7 +414,7 @@ extern "C" DLLEXPORT
+@@ -420,7 +420,7 @@ extern "C" DLLEXPORT
break;
}
default:{
@@ -24,16 +24,16 @@ index 7f66d23..33a297a 100644
shortusage(diag);
return 1;
}
-@@ -500,7 +500,7 @@ extern "C" DLLEXPORT
+@@ -506,7 +506,7 @@ extern "C" DLLEXPORT
usage(diag,false,false);
- const char *gstocall = whichPI(diag, options.verbose, options.gsregbase.value.c_str(),options.GSToUse.value.c_str());
+ const char *gstocall = whichPI(diag, options.verbose(), options.gsregbase.value.c_str(),options.GSToUse.value.c_str());
if (gstocall != 0) {
- diag << "Default interpreter is " << gstocall << endl;
+ errstream << "Default interpreter is " << gstocall << endl;
}
getglobalRp()->explainformats(diag);
return 1;
-@@ -577,13 +577,13 @@ To get the pre 8.00 behaviour, either use -dNOEPS or run the file with (filename
+@@ -589,13 +589,13 @@ To get the pre 8.00 behaviour, either use -dNOEPS or run the file with (filename
if (options.drivername.value.length() == 0) {
// try to find driver according to suffix of input file
if (!options.nameOfOutputFile) {
@@ -49,7 +49,7 @@ index 7f66d23..33a297a 100644
shortusage(diag);
return 1;
} else {
-@@ -592,7 +592,7 @@ To get the pre 8.00 behaviour, either use -dNOEPS or run the file with (filename
+@@ -604,7 +604,7 @@ To get the pre 8.00 behaviour, either use -dNOEPS or run the file with (filename
errstream << "No explicit output format specified - using " << suffixDriverDesc->symbolicname << " as derived from suffix of output file" << endl;
options.drivername = suffixDriverDesc->symbolicname;
} else {
@@ -58,7 +58,7 @@ index 7f66d23..33a297a 100644
// usage(errstream);
getglobalRp()->explainformats(diag); // ,true);
return 1;
-@@ -611,13 +611,13 @@ To get the pre 8.00 behaviour, either use -dNOEPS or run the file with (filename
+@@ -623,13 +623,13 @@ To get the pre 8.00 behaviour, either use -dNOEPS or run the file with (filename
}
const DriverDescription *currentDriverDesc = getglobalRp()->getDriverDescForName(options.drivername.value.c_str());
if (currentDriverDesc == 0) {
@@ -74,7 +74,7 @@ index 7f66d23..33a297a 100644
return 1;
}
-@@ -625,7 +625,7 @@ To get the pre 8.00 behaviour, either use -dNOEPS or run the file with (filename
+@@ -637,7 +637,7 @@ To get the pre 8.00 behaviour, either use -dNOEPS or run the file with (filename
if (driveroptions && strequal(driveroptions, "-help") ) {
ProgramOptions* dummy = currentDriverDesc->createDriverOptions();
if (dummy->numberOfOptions() ) {
@@ -83,7 +83,7 @@ index 7f66d23..33a297a 100644
dummy->showhelp(diag,false,false);
}
delete dummy;
-@@ -635,7 +635,7 @@ To get the pre 8.00 behaviour, either use -dNOEPS or run the file with (filename
+@@ -647,7 +647,7 @@ To get the pre 8.00 behaviour, either use -dNOEPS or run the file with (filename
// TODO:
// Check for input file (exists, or stdin) stdout handling
if (!options.nameOfInputFile) {
@@ -92,7 +92,7 @@ index 7f66d23..33a297a 100644
return 1;
}
// an input file was given as argument
-@@ -646,23 +646,23 @@ To get the pre 8.00 behaviour, either use -dNOEPS or run the file with (filename
+@@ -658,23 +658,23 @@ To get the pre 8.00 behaviour, either use -dNOEPS or run the file with (filename
convertBackSlashes(options.nameOfInputFile);
if (!fileExists(options.nameOfInputFile)) {
diff --git a/04-fix-obsolete-LIBPNG_LDFLAGS.patch b/04-fix-obsolete-LIBPNG_LDFLAGS.patch
index fe6679c7034e..da03100d8b43 100644
--- a/04-fix-obsolete-LIBPNG_LDFLAGS.patch
+++ b/04-fix-obsolete-LIBPNG_LDFLAGS.patch
@@ -11,7 +11,7 @@ file. This patch fixes this by removing there also
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/config/pstoedit.pc.in b/config/pstoedit.pc.in
-index 3131ac5..ffda220 100644
+index 3131ac5..ffda220 100755
--- a/config/pstoedit.pc.in
+++ b/config/pstoedit.pc.in
@@ -7,5 +7,5 @@ Name: pstoedit
diff --git a/05-fix-plugin-loading.patch b/05-fix-plugin-loading.patch
deleted file mode 100644
index 259d7d67b695..000000000000
--- a/05-fix-plugin-loading.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From: James Cowgill <jcowgill@debian.org>
-Date: Mon, 9 May 2016 22:31:45 +0100
-Subject: fix plugin loading
-
-Disable broken if-check in plugin load code so that plugins can be successfully loaded from PSTOEDITLIBDIR.
-
-The plugin load code was checking pluginsloaded before trying to load plugins from PSTOEDITLIBDIR
-Unfortunately code further up in the method sets pluginsloaded even if no plugins were found in
-previous places. This patch restores the old 3.62 behaviour of not checking pluginsloaded before
-searching for plugins in PSTOEDITLIBDIR.
-
-Bug-Debian: http://bugs.debian.org/813316
----
- src/pstoedit.cpp | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/pstoedit.cpp b/src/pstoedit.cpp
-index 33a297a..833abf2 100644
---- a/src/pstoedit.cpp
-+++ b/src/pstoedit.cpp
-@@ -282,11 +282,11 @@ static void loadpstoeditplugins(const char *progname, ostream & errstream, bool
- }
-
- #ifdef PSTOEDITLIBDIR
-- if (!pluginsloaded) {
-+ //if (!pluginsloaded) {
- // also try to load drivers from the PSTOEDITLIBDIR
- loadPlugInDrivers(PSTOEDITLIBDIR, errstream,verbose);
- pluginsloaded = true;
-- }
-+ //}
- #endif
-
- // delete[]plugindir;
diff --git a/PKGBUILD b/PKGBUILD
index 0efeb31469be..3fd679cc36e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
_srcname=pstoedit
pkgname=pstoedit-nomagick
-pkgver=3.70
-pkgrel=6
+pkgver=3.71
+pkgrel=1
pkgdesc='Translates PS/PDF graphics to other vector formats (no ImageMagick dependency)'
arch=('i686' 'x86_64')
url='http://www.pstoedit.net/'
@@ -15,19 +15,16 @@ provides=('pstoedit' 'libpstoedit.so')
conflicts=('pstoedit')
source=("https://sourceforge.net/projects/pstoedit/files/pstoedit/${pkgver}/${_srcname}-${pkgver}.tar.gz"
'02-errors-to-stderr.patch'
- '04-fix-obsolete-LIBPNG_LDFLAGS.patch'
- '05-fix-plugin-loading.patch')
-sha256sums=('06b86113f7847cbcfd4e0623921a8763143bbcaef9f9098e6def650d1ff8138c'
- '66cd2bd3f92aa4ba57c916f721acd8c42c07fffea5fbc81f075853dab845d6d8'
- '3320bbcf6ba33d70213897f41c31c158d4bb4284e17b061ed8d1c38c1ee5a8b8'
- 'edec8010f6f05126047ce8f9facf1c36a2c0480a0bac14469b8ffb31a7722625')
+ '04-fix-obsolete-LIBPNG_LDFLAGS.patch')
+sha256sums=('0589cd22cd9c23dee12d9bc9f26760f872185d8a1fb72a05bc58f6b824cfbc95'
+ '3ab9c962cb70744f984083755eafcf6e62b3b603ad060b5a078bcc3bda389448'
+ 'c5a3fd24ff4d57ac7106ee4f9f19e0fb1cd94cbaf7ad53a8ff979bcfe7173139')
prepare() {
cd "${_srcname}-${pkgver}"
patch -Np1 -i "${srcdir}/02-errors-to-stderr.patch"
patch -Np1 -i "${srcdir}/04-fix-obsolete-LIBPNG_LDFLAGS.patch"
- patch -Np1 -i "${srcdir}/05-fix-plugin-loading.patch"
}
build() {