summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Böger2016-07-21 12:18:38 +0200
committerLukas Böger2016-07-21 12:18:38 +0200
commit29af58613be4dcbaf71a008eb6ee9703d791e317 (patch)
tree01bf44c8a7bf717af8081cbc7e2344a1dc38872d
downloadaur-29af58613be4dcbaf71a008eb6ee9703d791e317.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD39
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b36e92b4438
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = psurface
+ pkgdesc = Piecewise linear bijections between triangulated surfaces
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = http://numerik.mi.fu-berlin.de/dune/psurface/index.php
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = gcc-libs
+ source = https://github.com/psurface/psurface/archive/psurface-1.3.1.tar.gz
+ md5sums = b7b0bb4221a162926d599702ff004d9a
+
+pkgname = psurface
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..234fc9d64b90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Lukas Böger <dev___AT___lboeger___DOT___de>
+
+pkgname=psurface
+pkgver=1.3.1
+pkgrel=1
+
+pkgdesc='Piecewise linear bijections between triangulated surfaces'
+arch=('i686' 'x86_64')
+
+url='http://numerik.mi.fu-berlin.de/dune/psurface/index.php'
+license=('custom')
+
+depends=('gcc-libs')
+
+source=("https://github.com/psurface/psurface/archive/${pkgname}-${pkgver}.tar.gz")
+
+md5sums=('b7b0bb4221a162926d599702ff004d9a')
+
+build() {
+ cd "${pkgname}-${pkgname}-${pkgver}"
+
+ ./makedist.sh
+
+ cd lib${pkgname}-${pkgver}
+
+ autoreconf -sfi
+
+ ./configure --prefix=/usr
+
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgname}-${pkgver}/lib${pkgname}-${pkgver}"
+
+ make install DESTDIR="${pkgdir}"
+
+ install -m644 -D COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}