summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072018-07-03 17:11:46 +0200
committersL1pKn072018-07-03 17:11:46 +0200
commit6479d08c0e6325c59de977ef68153a6d3dc242e6 (patch)
tree91c39f7fd9a69866ada42e12d5e3cda340e17511
downloadaur-6479d08c0e6325c59de977ef68153a6d3dc242e6.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD42
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5fcf42d1fb2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Tue Jul 3 15:11:46 UTC 2018
+pkgbase = psvimgtools-git
+ pkgdesc = Decrypt Vita CMA backups. (GIT version)
+ pkgver = v0.1.3.gf446c56
+ pkgrel = 1
+ url = https://github.com/yifanlu/psvimgtools
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ depends = libgcrypt
+ depends = zlib
+ provides = psvimgtools
+ conflicts = psvimgtools
+ source = git+https://github.com/yifanlu/psvimgtools.git
+ sha256sums = SKIP
+
+pkgname = psvimgtools-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60d439b5a0d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=psvimgtools-git
+pkgver=v0.1.3.gf446c56
+pkgrel=1
+arch=('x86_64')
+pkgdesc="Decrypt Vita CMA backups. (GIT version)"
+url='https://github.com/yifanlu/psvimgtools'
+license=('MIT')
+depends=('libgcrypt'
+ 'zlib'
+ )
+makedepends=('git'
+ 'cmake'
+ )
+conflicts=('psvimgtools')
+provides=('psvimgtools')
+source=('git+https://github.com/yifanlu/psvimgtools.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd psvimgtools
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+
+ cd build
+ cmake ../psvimgtools \
+ -DCMAKE_INSTALL_PREFIX=/usr
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+
+ install -Dm644 psvimgtools/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}