summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2014-11-28 11:46:42 +0200
committerAdrian Perez de Castro2015-07-13 21:57:45 +0300
commit33aa9e855f83bf13af15b7bd2b9a54062639899e (patch)
tree794ce5bce980e193a46739cc5046a3ae141aa0f3
downloadaur-33aa9e855f83bf13af15b7bd2b9a54062639899e.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
-rw-r--r--license.txt2
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3201243b261f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pswd
+ pkgdesc = A pseudo-random password generator
+ pkgver = 3.1.0
+ pkgrel = 1
+ url = https://pswd.davidwaring.net/info.html
+ arch = any
+ license = custom
+ depends = python
+ source = https://gitlab.davidwaring.net/dave/pswd/raw/1a547d7a6/python/pswd
+ source = license.txt
+ sha512sums = c3c73fa8ad5b9ff9e8e76be55113ef1a810548c31acd449aa8f5117aff08eec8e79a78c2d512a5d628f4cbd309d29df5c3a6f3c6897b633852aa562dd7d69bf7
+ sha512sums = 3396eb172dc6f467e153367492a14c89a1dcd06b0e445aacc71ab35f11984a9f2d666c40741b1b312c74fe54b81ca0e09a33643f63c97286d8ec13fd5f7df177
+
+pkgname = pswd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5560b28ed4bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
+pkgname='pswd'
+pkgdesc='A pseudo-random password generator'
+pkgver='3.1.0'
+pkgrel='1'
+arch='any'
+license=('custom')
+depends=('python')
+url='https://pswd.davidwaring.net/info.html'
+source=('https://gitlab.davidwaring.net/dave/pswd/raw/1a547d7a6/python/pswd'
+ license.txt)
+sha512sums=('c3c73fa8ad5b9ff9e8e76be55113ef1a810548c31acd449aa8f5117aff08eec8e79a78c2d512a5d628f4cbd309d29df5c3a6f3c6897b633852aa562dd7d69bf7'
+ '3396eb172dc6f467e153367492a14c89a1dcd06b0e445aacc71ab35f11984a9f2d666c40741b1b312c74fe54b81ca0e09a33643f63c97286d8ec13fd5f7df177')
+
+package () {
+ install -Dm755 "${srcdir}/pswd" \
+ "${pkgdir}/usr/bin/pswd"
+ install -Dm644 "${srcdir}/license.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
+}
diff --git a/license.txt b/license.txt
new file mode 100644
index 000000000000..ba516794df25
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,2 @@
+The original author does not indicate which license the source code is used
+for the software. Therefore, it is assummed to be in the public domain.